Ideas? Slow response in RubyMine 3.2.3 on OSX 10.6

The editor freezes when I type or try to complete something. So I would type a series of characters and nothing happens for several seconds and then they appear. During this time the CPU spikes and it looks like it is swapping memory. I did not have this problem with an earlier version of the IDE. It's not really useable so I'd appreciate any ideas.

I've seen reports say it has something to do with looking for gems. I do see a "Missing Gem" error but I cannot figure out how to turn this off. The error appears but does not say which gem is missing. When I try to install the missing gems, none are installed but the error persists. Is there a way to turn off the missing gem detection?

Also, I've seen postings that it had something to do with the cache, which I've cleared, but it did not fix it.

Details: the latest version 3.2.3 on my MBP running Snow Leopard. I am running in 32-bit mode.

11 comments
Comment actions Permalink

Please attach RubyMine threaddumps and logs. For this

1. click on RubyMine | Help | Reveal Log in Finder
2. compress directory with logs and threaddumps and attach it to this topic. You may exclude all idea.log.xxx files except "idea.log"

0
Comment actions Permalink

Hello there.

I have exactly the same issue with Rubymine (32-bit) on my Mac Pro running Snow Leopard.
Switching from an application to Rubymine creates a processor spike, during which any key-press gets delayed and then replayed after the spike. Coding within a file in Rubymine is okay, but changing tabs or focusing on a tool window running for example rails console, spikes as well.

I have attached the log and a cpu snapshot (following these instructions: http://devnet.jetbrains.net/docs/DOC-1144 ).

PS: I definitely do not mean to hijack this thread, I just want to say that it is not just Edwin having issues (glad that is not just me either).



Attachment(s):
idea copy.log.zip
RM-107.494_jimmi_12.08.2011_13.42.37.zip
0
Comment actions Permalink

Dimitris,

Thank you for the snapshot, it shows several bottlenecs. See http://youtrack.jetbrains.net/issue/RUBY-9158. Try to disable Preferences | Inpsections | Cucumber | Duplicated step definitions inspection, I think it will help.

0
Comment actions Permalink

@Roman, thanks for the response. I emailed you the information you requested.

0
Comment actions Permalink

@Roman, thanks for the response. I emailed you the information you requested.

Thanks, according to threaddumps Shoult structure view often eats CPU. Could you also capture a CPU snapshot (see http://devnet.jetbrains.net/docs/DOC-1144). We are interesing in moments when typing freezes. Several snapshots desired (one snapshot may show smth else)

The editor freezes when I type or try to complete something. So I would type a series of characters and nothing happens for several seconds and then they appear. During this time the CPU spikes and it looks like it is swapping memory. I did not have this problem with an earlier version of the IDE. It's not really useable so I'd appreciate any ideas.

It is known for Gemfile editing. Also try to turn off Cucumber duplicate steps inspection (after you've capture a snapshot)

When I try to install the missing gems, none are installed but the error persists. Is there a way to turn off the missing gem detection?

Do you use bundler? If yes please send your Gemfile, Gemfile.lock and screenshot of Libraries node content in Project View. Warning appears when bundler check tells that not all dependencies are satisfied.

Is there a way to turn off the missing gem detection?

RubyMine | Preferences | Notifications | Gem Manager, change "Display" value to "Ballon" or "Ignore"

0
Comment actions Permalink

Thanks, according to threaddumps Shoult structure view often eats CPU. Could you also capture a CPU snapshot (see http://devnet.jetbrains.net/docs/DOC-1144). We are interesing in moments when typing freezes. Several snapshots desired (one snapshot may show smth else)


Never mind, I did not save the plist file before restarting the IDE :-(.  The link tells me to install some software, but it asks me for a license key so I don't understand what to do here. Also, I downloaded yourkit mac intel version 9.5.6. Is this right?


Do you use bundler? If yes please send your Gemfile, Gemfile.lock and screenshot of Libraries node content in Project View. Warning appears when bundler check tells that not all dependencies are satisfied.


Is there a way to turn off the missing gem detection?

RubyMine | Preferences | Notifications | Gem Manager, change "Display" value to "Ballon" or "Ignore"


No my app does not use bundler. Thanks for the Gem Manager pointer in settings as it did not appear when I did a search for "gem".

0
Comment actions Permalink

I uploaded the profile info (3 files) you requested to  ftp://ftp.intellij.net/.uploads/. The last profile  RM-107.494_edwingo_12.08.2011_15.31.35.zip had a few freezes recorded  when I was editing comments as if some asynchronous processing was causing  the freeze. I was running in 32-bit mode with more than 600MB free RAM on my  Mac. (I switched to 32-bit mode in a past attempt to fix this problem.)  Also, I turned off all Cucumber and Gems Inspections and the problem still persists. Thanks for your  help.

0
Comment actions Permalink

Edwin,

Thanks, see RUBY-9165 Ruby Structure view freezes AWT after editor tabs/tool windows switching.

0
Comment actions Permalink

Is there a way to turn off Structure View as a workaround until the bug is fixed? Thanks.

0
Comment actions Permalink

Roman,
Many thanks for your reply.

I deactivated the inspection you mentioned but I am unsure if it made a difference or not. I used a dummy project that doesn't have the cucumber gem (or any kind of test suite actually) and I captured a couple of CPU snapshots (and the logs) while switching between open files/tabs and switching between code view and the rails console tool window (attached). While there is a lot of CPU activity, there was no delay for keypresses.

I also tried to eliminate the possibility of external applications that could cause this behaviour to RubyMine. I suspected that a running Time Machine backup might be playing a role, but that was not the case. After a lot of experimenting I found that a utility I use, that gathers the menus of the active application, was causing CPU spikes while switching from and to RubyMine. I deactivated that utility and RubyMine became responsive again (I could not any longer replicate the issue I originally reported).

This might not be of help to anyone else, but I run RubyMine without an active project and captured a CPU snapshot while I was opening and hovering over menus (attached). The activity monitor was showing the same 100% spikes that I was experiencing before.
I think I recall a setting regarding menus of RubyMine (or maybe IntelliJ) in Mac OS X, but I had a quick look and could not find it. Is this a known bug?



Attachment(s):
RM-107.494_jimmi_15.08.2011_21.56.17 (opening menus).zip
idea (opening menus).log.zip
idea log (switching tabs and to console).zip
RM-107.494_jimmi_15.08.2011_22.10.20 (switching to console).zip
RM-107.494_jimmi_15.08.2011_22.04.13 (switching tabs).zip
0
Comment actions Permalink

Try to collapse structure view tool window:
Screen Shot 2011-08-16 at 12.34.22.png

0

Please sign in to leave a comment.