How to change the language associated with a file

I accidentally tagged a file as ruby rather than perl in RM -- now, no matter what I do, RM remembers that the file is Ruby.

I have searched through the docs for some way of  setting the file type and not found anything.

I have deleted and recreated the file, renamed it and so on. As soon as I move the file back to its orginal name RM flags it as ruby.

I *dont* want to have the file named .....pl.

Is there a way of geting RM to treat the file as perl without renaming it to end in .pl?

Russell

2 comments
Comment actions Permalink

Hi Russell,

Maybe this will help:

Go into Settings > Filetype
Select 'Ruby Files' under 'Recognized File Types'
Remove the pattern corresponding to the file in question from the 'Registered Patterns' box.

--Tor

1
Comment actions Permalink

Right you are nobashi!  RM puts the file name in there.  It never occurred to me to look. Removing the filename leaves it as untyped so when you open it you are prompted to set the type again.


Russell

0

Please sign in to leave a comment.