having problems with snv authentication

Hi

I have a svn repository on a remote machine that i access via ssh with a key which is password protected.

When first enabled version  control I was prompted for the usual details but suspect that I screwed something up because I never got the login to work.  Now I can't figure out how to access the svn configuration within RubyMIne.   

I'm probably missing something blindingly obvious -- would not be the first time :)

Russell

5 comments
Comment actions Permalink

Hmmmm... I managed to get the authentication dialogue box up (not sure how) but when I checked "Use private key" and filled in the key location and password and cliked OK the dialogue box was redisplayed with password option checked and  no errors.  

I then tried creating a new project and checking the source out and had exactly the same thing happen..

R

0
Avatar
Irina Chernushina
Comment actions Permalink

Hello Russell,

I can not say what's the reason without additional information.
Can you please add -Djavasvn.log=true to ideavm.exe.options, restart IDEA, repeat login attempt and after that attach idea.log here?

0
Comment actions Permalink

I've got a bit further with this now -- still now sure what real problem is.  One thing I should have made clear before is that I'm on a Mac -- how to I get extra dianostics?

I have been playing around with different approaches and now have idea working on a directory that I checked out manualy.  Obviously I can check stuff in manually too but it would be nice to be able to do it from the app.

I have a .ssh/config entry for the host which has the username, host and key specified.  I've tried using this alias (sshagent caches the creds so one is not normally prompted for the key password) and I wondered if this might be a better approach?  If the app isn't using the native ssh then this probably won't work.

anyway if you can tell me how to turn on the debugging I'll see what I can find out.

Russell

PS. is there a way to get email notification of responses?

0
Comment actions Permalink

I figured out what was wrong -- eventually :)

I got confused because the authentication realm was given as user@host so I assumed that I would not need the user since it was already known.

when I repeated the user name and put in the key details all worked as expected.

Perhap it would be better to strip the user@ from the realm and then literal idiots like me would not get confused ;)

Russell

0
Comment actions Permalink

you always need to put in the username in the svn auth form even if it is part of the realm.

0

Please sign in to leave a comment.