RSpec tests don't run in 3.2 EAP or 3.1.1

U have just upgraded a Rails 2.3.11 app to 3.1.0.rc4 and I have just initiailized rspec. I can get my specs to run from inside the shell but in Ruby Mine I run into problems.

For  3.1.1 I get "no tests found" and for 3.2.EAP, when I run it I get unable to attach test reporter to test framework.

Can anyone point me in the right direction? I am using Ruby 1.9.2 with a dedicated gemset.

Here are the RSpec versions I have

rspec (2.6.0)
rspec-core (2.6.4)
rspec-expectations (2.6.0)
rspec-mocks (2.6.0)
rspec-rails (2.6.1)



Can anyone help point me in the right direction to get this working?

Thanks
3 comments
Comment actions Permalink

do you have a more sophisticated error message?

0
Comment actions Permalink

Hi,

Do you use bundler? Could you attach your project Gemfile. Also please check whether "rspec" gem is mentioned in list of libraries under "Libraries" node in project view.

0
Comment actions Permalink

Here is a snip of our Gemfile


group :test do
  gem 'database_cleaner'
  gem 'factory_girl'
  gem 'cotweet-fakeweb'
  gem 'mocha', :require => false
  gem 'rack-test'
  gem 'shoulda'
  gem 'timecop'
  gem 'rcov'
  gem 'metric_fu'
  gem 'launchy'
  gem 'factory_girl_rails'
  gem 'factory_girl'
  gem 'rr'
  gem 'cucumber-rails'
  gem 'capybara'
  gem 'faker'
  gem 'sqlite3'
  gem 'rspec'
end

group :development do
  gem 'annotate'
  gem 'yard'
  gem 'ruby-debug19'
  gem 'ruby-prof'
end

group :development, :test do
  gem 'jasmine'
  gem 'js-test-driver-rails'
  gem 'rspec-rails', '2.6.1'
end



I've looked at what gems are attached to the gemset being used and they are all the gems we need at the latest version. The same for what is under the Libraries list tree. All of the related rspec gems are there.

0

Please sign in to leave a comment.