Sluggish Response

I code for a large Rails project, ~200K LOC.

The latest EAP release appears to be very "sluggish" for lack of better term.  Even just switching between my browser and the RubyMine app, there appears to be a one to two second hesitation.  And then paging up/paging down also experiences minor delays before updating.

3.1.1 did not have these issues.

13 comments
Comment actions Permalink

Same here. Logged against Ruby-8690.

0
Comment actions Permalink

Having a similar experience with the latest Rubymine 107.261.. my system completely freezes up for about 10 seconds at a time while trying to make changes running in debug mode.

I think it might be being caused by the fsnotifier.exe as it seems to be chewing up my cpu each time everything freezes up.

If it's not that, it may be being caused because I couldn't use the latest ruby-debug gems that it prompts me to install when you try and run in debug mode. The error it output said that I needed to be running on Ruby 1.8.7 to use those gems.

Have rolled back to the 103.260 build and everything is working fine again..?

My environment:

WinXP - x86 - SP3
Ruby 1.8.6
No bundler
Rails 2.3.5

This main project that I'm on is quite large.. 120k or so and I only notice the freeze up when trying to use the editor with this project and 107.261

I have several other projects that I don't seem to run into this problem with but they're all using Ruby 1.9.2, rails 3+ and are MUCH smaller projects..?

0
Comment actions Permalink

I'm having the same problem.    When I do something like:  type a word, paste something, move to a new line, etc ....   Rubymine freezes and processor useage for it goes up to around 25%.   The freezing lasts between 3 and 10 seconds.   I've also notice (the memory reference at the bottom right corner of Rubymine), that the memory listed jumps up an extra 50 to 100MB and then drops back down to where it was after the freeze.  

I don't think my project is large at this point.  The 'app' folder is only about 35K and 30 files. Although it's a template with a few javascript files and 4 fairly large stylesheets.

Windows 7
Ruby 1.86
Rails 2.35




I guess a rollback would be an uninstall and re-install of the older version?

edit:   to add, it doesn't seem to be a problem when working with view.  I only have noticed this so far when working with controllers.

0
Comment actions Permalink

Reno,

Could you try our RubyMine 3.2 Beta (released today) and capture CPU snapshot (see http://devnet.jetbrains.net/docs/DOC-1144) if problem wont gone away.

0
Comment actions Permalink

Hi Roman.

I am happy to report that the latest RubyMine 3.2 Beta responsiveness is much improved. I gave it a spin for an hour to so last night and didn't come across any noticeable pauses whilst typing. I will carry out further testing today.


There was a slowdiwn issue with autocompletion and navigating to partials (where neither worked but would pause the IDE for a few seconds). I don't think this is related and has been reported in Ruby-8745.

Thanks for your efforts.

0
Comment actions Permalink

Hi Roman,

Yeah also have been trying out the new build.. it's MUCH better than the last one, but it's still freezing up occasionally on mine. not nearly as frequently as with the previous build though.

I managed to get it to freeze up like 3 or 4 times today but it's difficult to activate those snapshot buttons when it's about to happen because I can't tell if it's about to happen or not. When it does freeze up, those snapshot buttons are completely unresponsive.

I did manage to get it to freeze up just 10 mins ago and think I managed to get a memory snapshot around it when it happened. Just uploaded to the directory specified in that link.. The file name is RM-107.315_lhills_29.06.2011_19.58.22.zip

Hope it helps, I'll keep trying to catch a CPU dump and upload that when it happens again as well.

All in all though, it's at least workable with this current build. Much appreciated for looking into it.

Lucas

0
Comment actions Permalink

Lucas,

Thank you for the memory snapshot, but in case of freezes CPU snapshot is much more helpful and useful. Or instead of CPU snapshot at least several thread dumps using "jstack" cmdline utility.

0
Comment actions Permalink

I've been kind of busy and do mean to try and catch a freeze.  I'd agree with above that it only happens a couple of times an hour now.   I'll add that it only happens when in the controller.

The other thing that's been bugging me is the code completion or code prompting in the controller.   Like, if I type "@ticket", that use to prompt me with code completions right away.    Now about 1/2 or more of the time I have to manually press CTRL+SPACE and most of the time I have to wait a few seconds for RubyMine to gather the lists (little empty box with a spinner appears).    Sometimes I can do that and then right after use the same variable and RubyMine acts like it's already forgotton the complete lists and I have to wait another (say) 5 seconds for the list to re-generate.

Thanks for all the hard work - RubyMine is awesome (love it).



Attachment(s):
Untitled.png
0
Comment actions Permalink

Hello Reno,

It this behavior reproducible with the latest 3.2 RC build? http://blogs.jetbrains.com/ruby/2011/07/rubymine-3-2-release-candidate/

0
Comment actions Permalink

Hi Oleg,

I've switched over to use that version and so far (15 minutes in) it doesn't seem any better.   I still have to manually press CTRL+SPACE most of the time, then there's a 10-20 second wait for the list to load.   Maybe it just doesn't indicate it's trying to load the list in the background until you hit CTRL+Space.   Then RubyMine will seem to remember that list unless for awhile (sometimes for a few seconds, sometimes for a couple of minutes - I didn't see a pattern as to why Rubymine seems to forget the code hinting list it already loaded).   The project I'm on right now isn't very big at all.

I did notice once of these times that the memory counter jumped from 85MB to 152MB while this happened.  Then a couple of seconds later it dropped down to 138MB. (then still sitting there with me doing nothing else it jumped up to 192MB for awhile - then fell back to 150MB).   

BTW - that install file had no version information on it (unlike the other betas I've tried recently installed to a "Rubymine 3.2" folder by default).    The last few betas all installed to folders with their version numbers and identified themselves that way.    Of couse I didn't see "EAP" on this version either.   I only see the true version number "107.334" when looking at info off the help menu.    The last beta I had was 107.315.

I'm on Win7 32b right now.  Ruby 1.86 / Rails 2.35

0
Comment actions Permalink

Just to add - I've noticed that with all of the newer versions, spell check seems rather buggy.   Like you'll mis-spell a word and then correct it and it takes forever (or never) for Rubymine to catch on that you've corrected the word.

The attached screenshot element has been red underlined for 5 minutes now and a couple of times I even pasted the correct word over the top of it.   The only thing that works right now would be if I deleted the word and re-typed or re-pasted it.



Attachment(s):
Untitled.png
0
Comment actions Permalink

I've got another problem now.

I copied and pasted a respond_to block from one of my controllers to another.    Then changed the controller and actions for the redirect and Rubymine (5 minutes ago now) is still acting like I never chagned the words.  There are no IDE errors listed or anything.  It's like something whatever code there is to recheck a word after there is a change is not working or glitched after I opened Rubymine.

There's a lot of repeating errors in the log ...   don't know what any of it means.



Attachment(s):
idea.log.zip
Untitled.png
0
Comment actions Permalink

Hello Reno,

It seems that your problem is related with http://youtrack.jetbrains.net/issue/RUBY-8830
We haven't seen any of the described problems since we fixed that problem.

Regards,
Oleg

0

Please sign in to leave a comment.