Attaching locally installed gems in IntelliJ 10.0.3 not working

Hi,

I was wondering if someone could help me with a problem.

With 10.0.3 Ultimate edition I am trying to install the plugin cucumber.
However, when I try and install it via IntelliJ it fails at a step where is says it is contacting:

http://kenai.com/projects/jruby/pages/JRuby_Builtin_OpenSSL

So I tried installing the gems locally and they were put in /var/lib/gems/1.8/gems

I added this path to the classpath of the JRuby SDK (which I had setup earlier as a additional SDK).
However, when I go to click on 'Attach Gems...' I only see a gem whose root is:

/usr/lib/jruby/lib/ruby/gems/1.8/gems

Can anyone tell me how to tell the IntelliJ to pick up a localling installed gem from a particular place?

Thanks!
Robert

1 comment
Comment actions Permalink

To follow up this question:

I managed to half-solve the problem:

- the reference to http://kenai.com/projects/jruby/pages/JRuby_Builtin_OpenSSL just described the kind of SSL being used to connect for download
  - this was very confusing by the way
- the problem was that I was behind a firewall and was using a http proxy. For some reason the http_proxy was used fine to get the list of gems but then would fail when trying to get the actual gem
  - I imagine this is because the https proxy setting was using an incorrect default value.
     - Q: where is the https proxy set for plugins in IntelliJ?
- when I went used a direct connection to the internet the list of gems that was returned was different to before containing only github entries. For some reason the list from gems.rubyonrails.org was missing
  - after I removed github from the list of repositories the correct gems were shown
- I then was able to install cucumber (although it did require me to install gherkin first, not sure why this is not automatic i.e. you have to manually install gherkin first)

The half I did not solve is how to get IntelliJ to pick up any locally installed gems that were installed via 'gem install' on the command line.

0

Please sign in to leave a comment.