Plugin available for 10.5 EAP?

Hi - are there plans to release a version of the plugin for Intellij 10.5 EAP?
I ask because we're doing a joint Scala / Ruby project, and we'd like to use the latest Scala plugin - but it requires 10.5 EAP (at the moment), but there seems to be no Ruby plugin for this version.
Unless I've missed something...

15 comments
Comment actions Permalink

Hello Kornelis,

Of course we are planning to publish plugin version compatible with 10.5, however at the moment we have some unfinished tasks. Once they are completed we'll publish it.

Regards,
Oleg

0
Comment actions Permalink

We rewrote our Gem manager UI and changed workflow. Now attached gems settings are dropped and bundler Gemfile will be used instead of them. We need some time for stabilizing this feature and testing.

0
Comment actions Permalink

Any chance that the 10.5 plugin might be released soon?  The new features, particularly Chrome JavaScript debugging, are very tempting, but no Ruby support is a blocker.

--Mike

0
Comment actions Permalink

Any update here? We're blocking on this as well.

0
Comment actions Permalink

Just a heads up.  The download page for the 10.5 RC includes a section on "Updated Ruby, Python, Scala and PHP Plugins" -- but, there aren't compatible versions for either Ruby or Python available, yet.

--Mike

0
Comment actions Permalink

Now that 10.5 is officially released, what is the timeframe for a compatible Ruby plugin?

-Reggie

0
Comment actions Permalink

I'm also hoping for an answer to this.

Most everything on the JetBrains website implies that an updated Ruby plugin for 10.5 is a done deal, which is apparently not the case.

- David

0
Comment actions Permalink

Hello guys,

We are going to publish it in the couple of days. Plugin build for IDEA 10.5 is under QA processing at the moment.
Sorry for such inconveniences.

Regards,
Oleg

0
Comment actions Permalink

Hello everyone,

We've got good news for you. Plugin for IntellIJ IDEA 10.5 is available via plugin manager.

Regards,
Oleg

0
Comment actions Permalink

Thank you Oleg. We appreciate the hard work that the team has put into the product.

-Reggie

0
Comment actions Permalink

Sadly, my IDEA 10.5 plugin manager still shows the Ruby plugin as incompatible and there is no updated version available. The plugin version displayed is 3.1.17343

0
Comment actions Permalink

It's a bug because of the version number format (3.1 is considered older). The workaround is to uninstall the old Ruby plug-in, restart IDEA, then install 3.1 version which is the latest.

Note that this Ruby plug-in version has known performance issues which will be addressed in the next update.

0
Comment actions Permalink

OK, thanks. I may just wait for the next update.

0
Comment actions Permalink

Hello,

Plugin update with fixed performance problems is out.

Regards,
Oleg

0
Comment actions Permalink

Excellent, thank you. Downloading now :)

0

Please sign in to leave a comment.