Ruby 1.9.2 RSpec2 single example

I am unable to run a single example in Rubymine after swtiching from 1.8.7 to 1.9.2.  A single spec file works as does all specs.  When I run a single example, it starts the environment but does not run the test.  <home> is /Users/myusername and I'm on a Mac with OSX.

<home>/.rvm/rubies/ruby-1.9.2-p180/bin/ruby -e at_exit{sleep(1)};$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) <home>/.rvm/gems/ruby-1.9.2-p180/gems/ruby-debug-ide-0.4.17.beta3/bin/rdebug-ide --port 56887 -- <home>/work/rails3/myapp/vendor/ruby/1.9.1/bin/rspec <home>/work/rails3/myapp/spec/models/credit_account_spec.rb --require teamcity/spec/runner/formatter/teamcity/formatter --format Spec::Runner::Formatter::TeamcityFormatter --example CreditAccount\ sent\ \#credit_balance\ the\ fast\ way
Testing started at 1:00 PM ...
Fast Debugger (ruby-debug-ide 0.4.17.beta3, ruby-debug-base 0.11.26) listens on 127.0.0.1:56887

0 examples, 0 failures, 0 passed
Finished in 0.000184 seconds
Empty test suite.

Process finished with exit code 0


Though when I run the full spec file this example and the other examples all run fine.
2 comments
Comment actions Permalink

Hi Najitaka,


Fast Debugger (ruby-debug-ide 0.4.17.beta3, ruby-debug-base 0.11.26) listens on 127.0.0.1:56887



This line suggests that you don't have ruby-debug19 installed. Check your gem list to see if they are on your system:
ruby-debug-base19 (0.11.25)
ruby-debug-ide19 (0.4.12)
ruby-debug19 (0.11.6)

0
Comment actions Permalink

0.11.26 > 0.11.25 and 0.4.17.beta3 > 0.4.12.  Rubymine asks for 19x (0.11.26) even if you have 19 (0.11.25) installed.

I have the following gems installed for the devleopment environment.

archive-tar-minitar (0.5.2)
bundler (1.0.12)
columnize (0.3.2)
linecache19 (0.5.12)
rake (0.8.7)
ruby-debug-base19x (0.11.26)
ruby-debug-ide (0.4.17.beta3)
ruby-debug19 (0.11.6)
ruby_core_source (0.1.5)
rubygems-update (1.7.2)

0

Please sign in to leave a comment.