Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist !

I just installed RubyMine on a perfectly working config and I keep getting those stupid messages.

I can't get around it, it's a nightmare  X-(

12 comments
Comment actions Permalink

Hello,

Is there anybody out there at JetBrains ?

Thanks

0
Comment actions Permalink

See if you have any invalid SDK in Settings | Ruby SDK and Gems and remove it.

0
Comment actions Permalink

I have read a lot of stuff on this forum and tried many things to make it run since I got no reply from you for several days, so please don't give me the simple answer like that  :(

1/ I have no invalid SDK. The current SDK (ruby-1.9.2-p180) is detected automatically in the settings but with the message that I have no SDK !  ==>

When launching the tool (right after installation ! even after removing and re-installing), I get this message in a red background box
IDE internal error....

IDE internal error....


Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.: Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.
com.intellij.execution.ExecutionException: Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.
at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.validateSDK(RubyScriptRunner.java:233)
at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.runRubyScript(RubyScriptRunner.java:79)

.....
(see below full error message)

2/ Then I try to remove the detected SDK, I, do APPLY, quit the box and come back to verify it was removed, then when I try to install the SDK, by clicking on the ruby.exe or rubyw.exe in the proposed path (wich is good), I get this stupid message : The selected file is not a valid home for Ruby SDK



So there is no way I can get this tool to run even just one time. It fails right from the start :-(

I am running Windows 7 Pro on a Vaio laptop.


The full message that I get when launching the tool ==>

Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.: Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.
com.intellij.execution.ExecutionException: Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.
 at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.validateSDK(RubyScriptRunner.java:233)
 at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.runRubyScript(RubyScriptRunner.java:79)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.a(GemRunner.java:583)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.a(GemRunner.java:291)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.environment(GemRunner.java:118)
 at org.jetbrains.plugins.ruby.gem.GemUtil.buildGemUrlsForSDK(GemUtil.java:317)
 at org.jetbrains.plugins.ruby.ruby.sdk.RubySdkPatcher.prepareGemRootsAndRefresh(RubySdkPatcher.java:154)
 at org.jetbrains.plugins.ruby.ruby.sdk.RubySdkPatcher$2$1.run(RubySdkPatcher.java:116)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$TaskRunnable.run(ProgressManagerImpl.java:482)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:205)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:233)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:196)
 at com.intellij.openapi.progress.impl.ProgressManagerImpl$6.run(ProgressManagerImpl.java:358)
 at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:383)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:619)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:131)



com.intellij.execution.ExecutionException: Home path for ruby SDK 'ruby-1.9.2-p180' doesn't exist.
 at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.validateSDK(RubyScriptRunner.java:233)
 at org.jetbrains.plugins.ruby.ruby.run.RubyScriptRunner.runRubyScript(RubyScriptRunner.java:79)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.a(GemRunner.java:583)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.a(GemRunner.java:291)
 at org.jetbrains.plugins.ruby.gem.gem.GemRunner.version(GemRunner.java:133)
 at org.jetbrains.plugins.ruby.gem.gem.GemListPrefetcher.a(GemListPrefetcher.java:54)
 at org.jetbrains.plugins.ruby.gem.gem.GemListPrefetcher.access$000(GemListPrefetcher.java:20)
 at org.jetbrains.plugins.ruby.gem.gem.GemListPrefetcher$1.run(GemListPrefetcher.java:42)
 at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:383)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:619)
 at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:131)


0
Comment actions Permalink

What is your RubyMine version? Which Ruby distribution do you use? Is that RubyInstaller?
Try to delete your Ruby installation and install it again into a new directory without spaces, then configure it in RubyMine.

I've verified that RubyInstaller (1.9.2-p180) works fine with RubyMine 3.1.1 on Windows 7.

0
Comment actions Permalink

RubyMine version?                                    LATEST, 3.1.1, dowloaded last week
Which Ruby distribution do you use?           LATEST, Ruby 1.9.2

(my project works perfectly fine in Netbeans, or directly by console)

0
Comment actions Permalink

Please try to make another installation of Ruby into a new path without spaces and configure it in RubyMine.

What's the current full path to ruby.exe?
Did you use RubyInstaller?

0
Comment actions Permalink

Current directory is
C:\Ruby192\bin

there is no extra space

yeah I used the latest RubyInstaller (rubyinstaller-1.9.2-p180.exe) as RubyMine is detecting

0
Comment actions Permalink

Can you reproduce it with a fresh Ruby installation in a different directory?
Does it help if you delete .RubyMine31 directory from C:\Users\<user name>\ directory to start from scratch with all the default settings?

0
Comment actions Permalink

I removed the .RubyMine31 directory.

The IDE isn't failing on launch and no SDK is configured.

When I try to configure the SDK, it suggests the C:\Ruby192\bin directory and I click on this ->

C:\Ruby192\bin\RUBY.EXE

or

C:\Ruby192\bin\RUBYW.EXE

and I always get this message :
The selected file is not a valid home for Ruby SDK




I don't want to mess with my Ruby installation as it is perfectly working, either through console or with NetBeans
0
Comment actions Permalink

It should be ruby.exe, not RUBY.EXE.

Why does this file has a name with all capital letters in your installation? In the default installation it's "ruby.exe".

Does it help if you change the case of the file name?

0
Comment actions Permalink

Indeed, the problem seems to be caused by the capital letters in the file name (extension). It will be fixed in the future update:
http://youtrack.jetbrains.net/issue/RUBY-8280 .

Not sure why/how you've managed to get such installation as by default the name is in lower case.

0
Comment actions Permalink

I don't know, I just ran the RubyInstaller...

0

Please sign in to leave a comment.