RM won't run older rails version project

I need to update a project that was built on rails 2.3.8, but when I try to run it I get the following:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/bborun/RubymineProjects/memms/script/server -b 0.0.0.0 -p 3000 -e development
/Library/Ruby/Site/1.8/rubygems.rb:274:in `activate': can't activate rails (= 2.3.10, runtime) for [], already activated rails-3.0.5 for [] (Gem::LoadError)
 from /Library/Ruby/Site/1.8/rubygems.rb:216:in `try_activate'
 from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
 from /Users/bborun/RubymineProjects/memms/script/../config/boot.rb:55:in `load_initializer'
 from /Users/bborun/RubymineProjects/memms/script/../config/boot.rb:38:in `run'
 from /Users/bborun/RubymineProjects/memms/script/../config/boot.rb:11:in `boot!'
 from /Users/bborun/RubymineProjects/memms/script/../config/boot.rb:110
 from /Users/bborun/RubymineProjects/memms/script/server:2:in `require'
 from /Users/bborun/RubymineProjects/memms/script/server:2
 from -e:1:in `load'
 from -e:1

Process finished with exit code 1


How can I get rails to use the version specified in environment.rb (pre-rails3)?

1 comment
Comment actions Permalink

Hi Basil.

This doesn't solve your problem but I have several old Rails projects (1.6, 2.3.1, 2.3.4 and 2.3.5) that work correctly with RedMine 3.0.1 and 3.1.1.

0

Please sign in to leave a comment.