Upgraded to RubyMine to 3.1, can't see gems (rake)?

I have installed rake (0.8.7)
I have 'attached' it in the rubymine interface.
But all rake keywords continue to show up as underlined with the tooltip "Cannot find [namespace/task/desc/sh/FileList/mkpath]"


I installed rake on the command line (I'm on mac snow leopard) - I only have one ruby version 1.9.2 using rvm, which rubymine has picked up (the rvm gemset is global)

I have even tried 'installing' the gem from within the rubymine screen and then attaching it.


Is there something I can do to get rubymine to pick up and attach gems properly?
I haven't tried to use any gems other than rake as yet.

3 comments
Comment actions Permalink

Does your rake file require "rake" script in the beginning of file?

0
Comment actions Permalink

Aha, that fixed it. Thanks.
Maybe it worked before without requiring it, I'm not sure.

0
Comment actions Permalink

As far a I understand on run-time such "require 'rake'" call isn't obligatory in Rakefile and *.rake files. If I'm right please file a feature request related to improving our code insight engine for such cases (with explicit require call).

Update: See http://youtrack.jetbrains.net/issue/RUBY-8006 issue.

0

Please sign in to leave a comment.