noobie trying to configure Git w/in RubyMine

Hi,

I'm running RubyMine 3.01 on Mac, OS X 10.6.6. I'm working on a project that has just switched from CVS to Git for some of its VCS requirements. The Git repository is set up to authenticate using SSH. When I attempt to push, I'm prompted for my password. In Eclipse, which I use for development of other source files, Git is configured in the plug-in with a passphrase. I am not prompted for a password when I try to push or pull from within Eclipse. I don't know what I need to do in order to get RubyMine (or SSH plugin? or ssh-agent?) to use the passphrase that Eclipse is using.

I would appreciate some assistance.

Thanks.

2 comments
Comment actions Permalink

Hello Richard,

Could you please try to switch RubyMine to use native ssh in File | Settings | Version Control | VCSs | Git | SSH Executable?

Regards,
Oleg

0
Comment actions Permalink

Oleg,
I did try that, based on earlier posts on this topic. When I have it set up this way, I don't get prompted for a password or a passphrase, the process simply fails with a popup. It ways Pull Error fatal: The remote end hung up unexpectedly.

After doing a little bit more reading, I went to the terminal in OS X and tried ssh git-Xxxxx@host.com and it prompted me for the password. So, given that, I assume that there's something I need to do to set up ssh on the Mac. I took the id_sha and id_sha.pub files from Windows in VMWare (which is where Eclipse is installed and works with git) and copied them to the .ssh folder under my home directory. This did nothing much for me. There must be more that I need to do. I've tried reading man file entries for some of these but I think there's too much I don't know.

Thanks.

0

Please sign in to leave a comment.