a file is treated/displayed as plain text and cannot revert it

I created a new file, and forgot to type the extension. Then RubyMine asks how it should be displayed, so i thought: nevermind, entered the first option, and then changed the name to include the ".rb" file-extension.
Alas, unfortunately, it seems that every file which is called the same is handled as plain-text in all my rubymines.

So i have no syntax colouring, my tabs are wrong, ...

How can i revert this?

3 comments
Comment actions Permalink

Look at registered patterns in Settings | File Types

0
Comment actions Permalink

More specifically, remove the *.rb extension fron Text files

0
Comment actions Permalink

Great! That was the spot I was looking for. Actually, i had to remove unique_id.rb (which was how the file was called).

Thanks!

0

Please sign in to leave a comment.