Problems debugging in Rubymine 3

I have recently installed 3.0.1 (fresh) onto Ubuntu 10.04 with Ruby 1.9.2.

I have failed to get debugging working - on my first attempt I was prompted to upgrade some gems (I think) which didn't work.  Following advice in comments on JetBrains blog I have now removed all ruby-debug* gems but I cannot reinstall them.  When I attempt to debug from within Rubymine I get a dialogue saying

The gem ruby-debug-ide required by the debugger is not currently installed. Would you like to install it?

When I say Yes I end up with:

Error running : Testapp
Failed to install gems. Following gems were not installed:
/home/mark/Dev/RubyMine-3.0.1/rb/gems/ruby-debug-ide-0.4.15.gem: Error installing ruby-debug-ide-0.4.15.gem:
ERROR: Failed to build gem native extension. /usr/local/bin/ruby mkrf_conf.rb Gem files will remain installed in /home/mark/.gem/ruby/1.9.1/gems/ruby-debug-ide-0.4.15 for inspection. Results logged to /home/mark/.gem/ruby/1.9.1/gems/ruby-debug-ide-0.4.15/ext/gem_make.out

The contents of the latter file are:
/usr/local/bin/ruby mkrf_conf.rb

I am a Linux, Ruby and Rubymine noob, so please respond with explicit instructions and assume nothing but incompetence and lack of knowledge.

---
Original message URL: http://devnet.jetbrains.net/message/5282531#5282531

2 comments
Comment actions Permalink

Manually installing ruby-debug-ide and ruby-debug-ide19 seems to have fixed this.  I will probably find out I have got the wrong versions somewhere...

*** LOCAL GEMS ***

ruby-debug-base19 (0.11.25.jb3, 0.11.24)
ruby-debug-ide (0.4.16)
ruby-debug-ide19 (0.4.12)

0
Comment actions Permalink

Hello Mark,

Thanks for pointing this out, this is already fixed and should work out of the box in RubyMine 3.1 coming soon.

Regards,
Oleg

0

Please sign in to leave a comment.