Weird keybinding issue

Hello, I'm rather new both here and as RubyMine user on OS X.  Using 3.0.1 and writing Ruby code, I'm getting stumped at the following: I want to type a "|" (and Rubyists will agree that it is a fairly important character in Ruby) like in the following

ALL.collect{|e| ... }

but everytime I hit that ⌥-shift-L key combination on my French AZERTY keyboard, instead of the | character I get a menu called "Load context" asking me for something.

I've tried to look at the menus in order to find that keybinding and change it to no avail.  Is there anyone who knows please?

BTW as a die-hard TextMate user, I find RubyMine very usable (though startup time is very slow) and I like it, am I doomed? :)

PS: I'm sent my registration asking for a free license for open-source project, still no answer after a week.  Is that expected?  Thanks.

4 comments
Comment actions Permalink

Hello again, I finally found where to remove the keybinding.  I wonder how many foreign characters keybindings are used for actions in RubyMine...  Would be nice if we could just type a key combination in the Preferences and see what Action is any is defined.

Cheers.

0
Comment actions Permalink

Hi Robert,

Would be nice if we could just type a key combination in the Preferences and see what Action is any is defined.

You need "RubyMine | File | Settings | Keymap" dialog, press "shortcut filter" button.
Screen shot 2011-01-09 at 1.37.09 PM.png

0
Comment actions Permalink

Thanks for your reply.  Nice to see  it is already present.

Now, if only someone could reply to my open source license submission for RubyMine, I'd be in Heaven ;-)

0
Comment actions Permalink

PS: I'm sent my registration asking for a free license for open-source project, still no answer after a week.  Is that expected?  Thanks.

In Russia we currently have long New Year & Christmas holidays and tomorrow is our first working day. I'm sure your request will be processed this week. Sorry for the inconveniences.

0

Please sign in to leave a comment.