jQuery IU and RubyMine code inspector errors

I am developing a Ruby on Rails (2.3.9) application on my Windows XP machine with RubyMine 2.0.2.  I use HAML/SASS for the views...and want to incorporate jQuery and jQuery UI for some rich content.  jQuery IU wants to work with a theme that uses a lot of background images (dropped into Rails /images folder). After I add 'jquery-ui-1.8.6.custom.css' (from the default download) to my stylesheets, then look at that CSS file with RubyMine, the code inspector indicates a lot of red errors...which makes me a little uncomfortable.

First, the many background-images are referenced as 'url(images/xxx.png)'...without the leading '/'.  This inspected as an error (red)...which corrected (green) when I added leading slashes as 'url(/images/xxx.png)'.  I did a search-replace that seemed to solve these.

Second, a Firefox button workaround throws an 'invalid pseudo class' inspector error on the '-moz-focus-inner' element of the following:

/* workarounds */
button.ui-button::-moz-focus-inner { border: 0; padding: 0; } /* reset extra padding in Firefox */

Third, an IE datepicker element throws an 'term expected' inspector error on the 'mask ()' element of the following:

/* IE6 IFRAME FIX (taken from datepicker 1.5.3 */
.ui-datepicker-cover {
    ...
    filter: mask(); /*must have*/
    ...

I want a stable UI library that I can use with confidence. I don't like the idea of changing a 'standard' library...especially since I will want to use updates that will overwrite any changes I have to make now.  Am I missing something?  I want to use this library properly...just not sure I am doing it right.  Any comments will be appreciated!

Please sign in to leave a comment.