require ... No such file to Load (but the program is working)

Friendly greetings !
I'm testing the latest rubymine EAP, under windows 7 32bits.

i compiled the gem "Barracuda" (OpenCL binding for Ruby).
The gem is written in c : http://github.com/lsegal/barracuda 

i included it in a new project.
i wrote a little program that compile/execute perfectly, but ... in the IDE the editor show a warning for every require, include and method call on this gem.

I'm new to rubymine (and still in trial), what is the problem please ?

thank you

2 comments

Hello Laurent,

RubyMine wasn't able to process native extensions properly, thus you see this warning.
However we have an issue for this kind of problem: http://youtrack.jetbrains.net/issue/RUBY-4344
And similar problem: http://youtrack.jetbrains.net/issue/RUBY-6626
Feel free to vote, comment and track progress of it.

Best regards,
Oleg

0

Please sign in to leave a comment.