RubyMine for old versions of Rails(2.02)?

I'm still fairly new to Rails.   I've been training on Rails application development for the last two months with a basic text editor.   I'm starting to get comfortable and I'm ready to start using RubyMine full time.    At work, the Rails server is on a fairly old version of Rails and there's no plans to upgrade it (Rails:  2.02,  Gems 1.36, Ruby: 1.86).    I've matched my work development system to those versions.

I know there were massive changes in Rails after 2.0.x, like 1600 patches in 2.1 including the scaffold generator being completely changed to a restful scafold generator (from what I read).   Just out of curiousity, is there anything I should be aware of or any issues that might come up using RubyMine against such an old version like 2.0.2?

Thanks!

1 comment

Hello Reno,

> is there anything I should be aware of or any issues that might come up using RubyMine against such an old version like 2.0.2?

In general all stuff should work, probably our resolve/autocompletion features will be less accurate comparing to rails 2.3.x support

0

Please sign in to leave a comment.