RubyMine Windows: no rails 3 gem?

Hi!

I've installed RubyMine on Windows 7. I've also installed Ruby 1.8 and 1.9 and successfully attached them to RubyMine.

After that, i'm trying to attach gems. 'sqlite3-ruby' attached fine but 'rails' gem failed: there seems to be no rails 3 gem available.

How to resolve this issue?



Attachment(s):
rubymine_no_rails3.png
3 comments
Comment actions Permalink

Andrey,

Which RubyMine version do you use ?

0
Comment actions Permalink

It's RubyMine 2.0.2 build #RM-93.202

JetBrains download site is offline (download link at http://www.jetbrains.com/ruby/download/index.html#win giving a timeout error), so i had to find a distribution over the web. But i believe it's the lastest version. Funny thing is that i downloaded it from the JetBrains website, just using a link from an external site. :)

Well, this doesn't matter anyway.

0
Comment actions Permalink

Andrey,

We had some problems with electricity, blackout in almost whole city, but now all works ok. Yes, RubyMine 2.0.2 is our latest stable major release but it doesn't support rails 3.0. At the moment we are working on our next version 2.5 (see http://www.jetbrains.com/ruby/nextversion/index.html) which includes rails3 support. Our EAP (early access program) allows you to use or latest Rails 2.5 beta/night builds with rails 3 support. See http://confluence.jetbrains.net/display/RUBYDEV/RubyMine+EAP

0

Please sign in to leave a comment.