Debugger does not work - no breakpoints hit (MacOSX)

Hello,

I've read all threads regarding the problem very carefully. I attached the line to the preferences file (idea pref file) like many said I should.
I reinstalled everything - no progress.

The ide says "connected" but the breakpoints are ignored. The application runs smoothly, there is server output:

Server Output
usr/bin/ruby -r /Applications/RubyMine 2.0.2.app/rb/gems/rdebug-hack.rb -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift) /usr/bin/rdebug-ide --port 58843 -- /Volumes/TravelIQ/InlineBooking/script/server -p 3000 -b 0.0.0.0 -e development
Fast Debugger (ruby-debug-ide 0.4.9) listens on :58843
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.1.0 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
** [Hoptoad] Notifier 2.0.18 ready to catch errors
Travel IQ version 18344
Loading tzinfo files to stop threaded loading problems
Done loading tzinfo files




All gems are installed:

*** LOCAL GEMS ***

actionmailer (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0, 1.3.6)
actionpack (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0, 1.13.6)
actionwebservice (1.2.6)
activerecord (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0, 1.15.6)
activeresource (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0)
activesupport (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0, 1.4.4)
acts_as_ferret (0.4.4, 0.4.3)
amqp (0.6.7, 0.6.0)
archive-tar-minitar (0.5.2)
BlueCloth (1.0.0)
bmabey-email_spec (0.1.3)
builder (2.1.2)
capistrano (2.5.9, 2.5.2)
cgi_multipart_eof_fix (2.5.0)
columnize (0.3.1)
commonwatir (1.6.5)
crack (0.1.7)
cucumber (0.3.104)
curb (0.5.4.0, 0.4.2.0)
daemons (1.0.10)
diff-lcs (1.1.2)
dnssd (1.3, 0.6.0)
eventmachine (0.12.10, 0.12.8)
fastthread (1.0.7, 1.0.1)
fcgi (0.8.7)
ferret (0.11.6)
firewatir (1.6.5)
gem_plugin (0.2.3)
geokit (1.5.0)
gruff (0.3.4)
highline (1.5.1, 1.5.0)
hoe (2.6.0)
hpricot (0.8.1, 0.6.164)
json (1.2.4)
json_pure (1.4.2)
libxml-ruby (1.1.3, 1.1.2, 0.9.7)
linecache (0.43)
mattetti-googlecharts (1.4.0)
mechanize (1.0.0)
mongrel (1.1.5)
mysql (2.8.1)
nanite (0.4.1.16)
needle (1.3.0)
net-scp (1.0.2, 1.0.1)
net-sftp (2.0.2, 2.0.1, 1.1.1)
net-ssh (2.0.15, 2.0.4, 1.1.4)
net-ssh-gateway (1.0.1, 1.0.0)
newrelic_rpm (2.9.5)
nokogiri (1.4.0, 1.3.3)
polyglot (0.2.9)
rack (1.1.0, 1.0.1, 1.0.0)
rails (2.3.8, 2.3.5, 2.3.4, 2.2.2, 2.1.0, 1.2.6)
rake (0.8.7, 0.8.3)
rdoc (2.4.3)
RedCloth (4.2.2, 4.1.1)
relevance-rcov (0.9.2.1)
rmagick (2.12.2, 2.12.1)
rspec (1.2.9, 1.2.8)
rspec-rails (1.2.9, 1.2.7.1)
ruby-debug (0.10.3)
ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.9)
ruby-openid (2.1.7, 2.1.2)
ruby-yadis (0.3.4)
ruby_core_source (0.1.4)
rubyforge (2.0.4)
rubynode (0.1.5)
rubyzip (0.9.1)
s4t-utils (1.0.4)
savon (0.7.6)
scrubyt (0.4.06)
selenium-client (1.2.16)
sqlite3-ruby (1.2.5, 1.2.4)
term-ansicolor (1.0.4)
termios (0.9.4)
treetop (1.4.2)
user-choices (1.1.6.1)
validatable (1.6.7)
webrat (0.4.4)
xml-simple (1.0.12)
xmpp4r (0.5, 0.4)


Any ideas?

Thanks in advance

Romano
5 comments
Comment actions Permalink

In addition (maybe it's important):

The imported project is on a extra Volume - meaning - not on the same volume as ruby or rubymine. (/Volumes/Project/ProjectFolder)
Don't think it is relevant, but who knows.

0
Comment actions Permalink

Hi Romano,

Please ensure you doesn't have symbolic links within your project. There are several known issues with them.

Please add this option to rubymine.vmoptions

-Druby.debug.output=true
This will enable debugger log in console. Restart rubymine and try to debug.

Regards,
Oleg

0
Comment actions Permalink

I have no symbolic links in my project.
Can't find rubymine.vmoptions anywhere on my computer. Where is it located.

I already added the line (it was mentioned in another thread) to /Applications/RubyMine\ 2.0.2.app/bin/idea.properties.
But I received no debug output (as far as I can see)


Regards Romano

0
Comment actions Permalink

Hi Romano,

Sorry for Mac case you should add this line to other file.

On Mac OS X open Info.plist located in /Applications/RubyMine-X.X.app/Contents, find the following:
<key>VMOptions</key>
<string>some options here</string>
Add line ruby.debug.output=true there.



Best regards,
Oleg
0
Comment actions Permalink

I encounter the same problem working with RubyMine 2.0.2 on Mac OS X 10.5.7. Debugger works fine on Idea's Ruby plugin but in RubyMine it silently omits all break points though reports in console that it's enabled:

/usr/bin/ruby -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift) /usr/bin/rdebug-ide --port 61955 -- /Users/username/dev/projectname/script/server -p 3000 -b 0.0.0.0 -e development
Fast Debugger (ruby-debug-ide 0.4.9) listens on :61955
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach


I had symlinks, but I've replaced them with folders. So, I have no idea how to fix this...
0

Please sign in to leave a comment.