Auto-indent behavior in 96.552 (OS X)

Is anyone else seeing strange auto-indent behavior in 96.552?  I find that in Ruby code, upon hitting <return>, the next line will be indented properly, but if you hit <return> again, it will de-dent to the first column.  And Haml auto-indent doesn't seem to be working at all.

It seems like such strange behavior that I figured it couldn't be a bug, and that there is possibly some new setting that I don't have set.

If this is indeed a bug, I will file one, but I wanted to check first.

6 comments
Comment actions Permalink

There's a new (?) option under Coding Style/General/Ruby - "Use indent relative to expressions start", maybe it is got to do something with it. But with this build, the indenting is working strange for me too, esp. in case statements.

0
Comment actions Permalink

This is happening to me as well running under Ubuntu and it's really getting annoying. I've tried toggling some of the new indent/smart enter options but I can't make it work like 2.0.2 does which respects the indent of the block you're currently in.

0
Comment actions Permalink

I do experience the same problem since upgrading from RM EAP 96.361.

Hubert
----
RM 96.552/MacOS X 10.6.4/MacPro 2x2.66GHz  Dual-Core Intel Xeon/7GB RAM

0
Comment actions Permalink

A bug has been filed for this issue.

0
Comment actions Permalink

I concur. This one is driving me nuts. Thanks for filing the bug.

0
Comment actions Permalink

Thanks you for submitting an issue, we are working hard to fix it.
Sorry for such inconviniences.

Best regards,
Oleg

0

Please sign in to leave a comment.