Subversion / SVN Authentication Issue

Hello,

since Rubymine 2.0.1RC1 I have the problem, that I can't authenticate anymore using svn+ssh to my subversion server. I get a popup "You are not authenticated to '...<my repo details>....'. To login, see pending notifications."

Where do I find the "pending notifications" so that I can login?

With RM 2.0 I had a similar issue, but here I got a popup dialog, where I specified my credentials and I was able to access the SVN server. RM 2.0 wouldn't remember it reliable so that I had to type it in every now and then.

My SVN command line client is working properly.

The authentication to the SVN server is done via SSL client cer files. I tried cert files with and without passphrase. Didn't change a thing though.

What should I do to access my SVN server again?

Regards,
Andreas

31 comments
Comment actions Permalink

I've just started getting this problem too. I'm using Rubymine 2.0.1 on Snow Leopard. Using subversion 1.6.

My commandline client works just fine.


John

0
Comment actions Permalink

I see this in the logfile a lot.

Not being able to access subversion in RubyMine is a big issue for me.

John

2010-01-22 10:25:14,128 [ 258865]   INFO - api.vcs.impl.VcsInitialization - Registering startup activity AFTER initialization  
java.lang.Throwable
 at com.intellij.openapi.vcs.impl.VcsInitialization.add(VcsInitialization.java:53)
 at com.intellij.openapi.vcs.impl.ProjectLevelVcsManagerImpl$7.run(ProjectLevelVcsManagerImpl.java:635)
 at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:691)
 at com.intellij.openapi.vcs.impl.ProjectLevelVcsManagerImpl.addInitializationRequest(ProjectLevelVcsManagerImpl.java:633)
 at org.jetbrains.idea.svn.SvnBranchConfigurationManager.loadState(SvnBranchConfigurationManager.java:205)
 at org.jetbrains.idea.svn.SvnBranchConfigurationManager.loadState(SvnBranchConfigurationManager.java:58)
 at com.intellij.openapi.components.impl.stores.ComponentStoreImpl.a(ComponentStoreImpl.java:301)
 at com.intellij.openapi.components.impl.stores.ComponentStoreImpl.access$000(ComponentStoreImpl.java:49)
 at com.intellij.openapi.components.impl.stores.ComponentStoreImpl$1.run(ComponentStoreImpl.java:89)
 at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:691)
 at com.intellij.openapi.components.impl.stores.ComponentStoreImpl.initComponent(ComponentStoreImpl.java:102)
 at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter.initializeInstance(ServiceManagerImpl.java:140)
 at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter$1.compute(ServiceManagerImpl.java:127)
 at com.intellij.openapi.application.impl.ApplicationImpl$10.run(ApplicationImpl.java:721)
 at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:691)
 at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:719)
 at com.intellij.openapi.components.impl.ServiceManagerImpl$MyComponentAdapter.getComponentInstance(ServiceManagerImpl.java:122)
 at com.intellij.util.pico.DefaultPicoContainer.getLocalInstance(DefaultPicoContainer.java:231)
 at com.intellij.util.pico.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:218)
 at com.intellij.util.pico.DefaultPicoContainer.getComponentInstance(DefaultPicoContainer.java:200)
 at org.picocontainer.alternatives.AbstractDelegatingMutablePicoContainer.getComponentInstance(AbstractDelegatingMutablePicoContainer.java:75)
 at com.intellij.openapi.components.ServiceManager.getService(ServiceManager.java:40)
 at org.jetbrains.idea.svn.SvnBranchConfigurationManager.getInstance(SvnBranchConfigurationManager.java:70)
 at org.jetbrains.idea.svn.SvnChangeProviderContext.<init>(SvnChangeProviderContext.java:62)
 at org.jetbrains.idea.svn.SvnChangeProvider.getChanges(SvnChangeProvider.java:75)
 at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListManagerImpl.java:392)
 at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.a(ChangeListManagerImpl.java:315)
 at com.intellij.openapi.vcs.changes.ChangeListManagerImpl.access$600(ChangeListManagerImpl.java:65)
 at com.intellij.openapi.vcs.changes.ChangeListManagerImpl$ActualUpdater.execute(ChangeListManagerImpl.java:227)
 at com.intellij.openapi.vcs.changes.UpdateRequestsQueue$MyRunnable.run(UpdateRequestsQueue.java:184)
 at com.intellij.lifecycle.SlowlyClosingAlarm$MyWrapper.run(SlowlyClosingAlarm.java:234)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
 at java.util.concurrent.FutureTask.run(FutureTask.java:138)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98)
 at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:207)
 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
 at java.lang.Thread.run(Thread.java:637)

0
Comment actions Permalink

Going back to 2.0 fixes the problem, instead of the useless error message I get an authentication dialog.

John

0
Comment actions Permalink

Hello,

'Notifications' are in the lower-right corner of the screen, you'll see red "!" sign there.

Please see description here http://youtrack.jetbrains.net/issue/IDEA-27271

0
Comment actions Permalink

Despite the message saying see notifications, there aren't any. No read "!" sign, clicking where it would be brings up an empty window saying 'no notifications'.

John

0
Comment actions Permalink

That's what happens in Rubymine 2.0.1 if that is equivalent to Idea 9.0.1

0
Comment actions Permalink

I am having this problem as well with rubymine 93.95.  No prompt for SVN auth comes up then it says svn authentication failed, check messages to log in.  In the messages area there is no exlamation point, then when clicked it says there are no messages.  Cannot find any other way to force auth box to come up.  This worked in 2.0 broken in 2.0.1

0
Comment actions Permalink

Here is a screen shot.  Never got a prompt, and the notification area is empty.
Screenshot.png

0
Comment actions Permalink

Hey guys any insight on this?  It is a major problem for me and makes 2.0.1 unusable.

0
Comment actions Permalink

Please attach logs here. Here is some useful info http://www.jetbrains.net/devnet/docs/DOC-1153

Regards,
Oleg

0
Comment actions Permalink

  Thanks for the reply.   This error is not causing any exceptions that are logged.  I tailed the current log, and ran it in a terminal window, there is no output when it does this failure to authenticate. Is there a way to change the logging level to debug or something?  Right now it seems like it just reports exceptions, and there is no exception when this occurs.  I am running on linux BTW.

0
Comment actions Permalink

What build number do you use?

0
Comment actions Permalink

I'm using Rubymine 2.0.1 on Max OS 10.6.2, build number in about dialog is #RM-93.95

John

0
Comment actions Permalink

Hi Oleg,
It is rubymine93.95  Version 2.0.1

0
Comment actions Permalink

Hi,

I am having the exact same problem trying to open an existing working copy as a directory in RubyMine 2.0.1. However, if instead of opening an existing working copy you check out your project through RubyMine to begin wth then things seem to work much better. When I opted to check out a new project RubyMine pompted me for my svn credentials, checked out the project, and now I am able to synchronize it with SVN. So perhaps this can serve as a work-around for some one.

Here is some information about my setup:

Ubuntu 9.10
RubyMine 2.0.1
SVN (client) 1.6.5 (incidentally, RubyMine used the 1.6 format when checking out)

Thanks,

Greg

0
Comment actions Permalink

Hello,

I tried to checkout from scratch, and I get no prompt to provide credentials. Again just the popup and no exclamation mark in the bottom bar.



Andreas

0
Comment actions Permalink

I have same issue too after resetting SVN on my MAC computer. I can enter "temporary" or "prermanent" acceptance, but it also should be the way to enter password.

0
Comment actions Permalink

Hello,

how did you exactly "reset" your SVN? Do you mean somehow inside RM or on OS level (running Windows here though).

Thanks,
Andreas

0
Comment actions Permalink

Hi Andreas,

Sorry for my delayed reply. I repeated the steps that I took to check out from scatch to make sure it still worked. Here is exactly what I did:

1. Launch RubyMine.
2. RubyMine should display the Welcome screen. If you have an existing project close it so that the Welcome screen is displayed.
3. Under Quick Start there are options to "Create New Project", "Open Directory", "Reopen Recent Project" and "Check out from Version Control"
4. Click "Check out from Version Control" and select Subversion from the menu.
5. Click on the + icon to add a new repository and fill in the repository URL
==> I think it's at this point that RubyMine prompts for your credentials (unfortunately RubyMine must have already saved my credentials somwhere because it let me browse and checkout immediately upon entering the repository URL)

Hope this helps!

Greg

0
Comment actions Permalink

remove ~/.svn content


0
Comment actions Permalink

Hi guys,

This problem was recently fixed in IntelliJ platform, thus fix will be available in RubyMine 2.0.2 coming soon.

Regards,
Oleg

0
Comment actions Permalink

I kept getting the same error no matter what I did, even in the latest IntelliJ IDEA EAP (94.273) for a Google Code project.

I'm not sure I solved it right, but I had to use relocate and change the URL to be HTTPS instead of HTTP. After the change in the repository URL everything checked in.

-Charlie

0
Comment actions Permalink

I returned to rubymine, which is supposed to be my fun project, and ran into this problem. I can't add any information to what is above; but please add me to the list of folks for whom RubyMine is unusable without a fix.
Eagerly awaiting 2.0.2.
Thanks,
Gordon

0
Comment actions Permalink

Hi @all,

while waiting for the new RM version (2.0.2) I tried to find a solution for this issue, too. This is the way, I got it working:

As above described I checked out my project via the RubyMine startpage. As long as I didnt't close RubyMine, the communication between RM and SVN worked until I restarted RM.

So I had a look in the RM configruation files and found in <project_root>/.idea/workspace.xml inside the path <project>/<component name="SvnConfiguration"> the two entries <option name="USER"> and <option name="password">

Since I setted the concerning values to the fitting SVN credentials and the following new start of RM the authentication workes again.

Might be that this a a quick and dirty solution with some security problems, but it can be the solution until we get the upcoming version 2.0.2...

Have a nice day.

0
Comment actions Permalink

Thanks Bernd,
I followed your advice and created a whole new project, creating a new working copy from svn and etc.
That seems to be working fine. In my case it wasn't even necessary to tweak the configuration
files.
So, thank you,
Gordon

0
Comment actions Permalink

Hi,
Ran into the same issue -
showed message at the bottom to check new notifications, but no notifications.

The way I could fix it is by creating another repository location - but with same location and a different project - but this time while I saved the username password, I saved the login info. This seems to give me access to my current project as well.

0
Comment actions Permalink

Oleg,
I am shocked you leave this issue like that unaddressed for more than 2 months without a fix or work around. I find this absolutely unacceptable.

0
Comment actions Permalink

Hi HeinRich,

This seems to be fixed in latest RubyMine 2.0.2 rc2 (according to http://youtrack.jetbrains.net/issue/IDEA-27271).
Latest build can be found at: confluence.jetbrains.net/display/RUBYDEV/RubyMine+EAP
Sorry for such inconveniences, but it took us much more time to publish final 2.0.2 than it was expected.

Regards,
Oleg

0
Comment actions Permalink

I am unable to log in to svn with 2.0.2 on an Intel Mac running Snow Leopard.

I get the login dialog, but my password is apparently not accepted.

Nothing obviously related goes in the Console.

How is this regression still not fixed?

Attach log file



Attachment(s):
idea.log.zip
0

Please sign in to leave a comment.