.rvmrc support in 95.314

If I put 'rvm use <ruby>@<gemset>' into my project .rvmrc file, RubyMine ignores it.

Platform: Ubuntu 10.04

3 comments
Comment actions Permalink

Please attach
1. real example of your .rvmrc file
2. full name of corresponding rvm sdk (in ~/.rvm/rubies/)
3. Please open RubyMine SDK and Gems settings. Which sdk is active there? Is your skd@gemset pair available in sdks combobox?
RubyMine should change project sdk in it's settings on project loading.

RubyMine updates sdk settings only on project reopening, RM doesn't listen ".rvmrc" file changes in already opened project

0
Comment actions Permalink

Here is the behavior I see:
- if I change rubies, or gemsets, RubyMine doesn't see the change until after I reboot my system, even if I restart RubyMine
- when I change the .rvmrc file, RubyMine doesn't pick up the change until after I reboot my system, even if I restart RubyMine

Here are the .rvm syntax I am using:

t30/.rvmrc:
rvm use 1.8.7@tst30

t23/.rvmrc:
rvm use 1.9.2@tst23

0
Comment actions Permalink

- if I change rubies, or gemsets, RubyMine doesn't see the change until after I reboot my system, even if I restart RubyMine

It is very strange... On each startup RubyMine scans content of ~/.rvm folder. Also RM listens file watcher for changes in ~/.rvm folder, at least you may close settings dialog, manually press "synchronize" button in RubyMine, then open Settings again and new sdk&gemset pair should appear.

- when I change the .rvmrc file, RubyMine doesn't pick up the change until after I reboot my system, even if I restart RubyMine

If .rvmrc file is under project root folder - it should be picked up on each project reopen, or at least RubyMine restart.

---
It works ok on my Mac. Probably it is ubuntu specific issue. We will check it on a Ubuntu machine.

0

Please sign in to leave a comment.