IronRuby and Rspec

Hi,

Should I be able to run rspec tests in RubyMine(2.0.2) using IronRuby 1.0?  RubyMine seemed to install/attach rspec gem w/out an error.

When I run the spec from the IDE I get an error message saying the "requre spec" cannot be loaded/found.

Running spec from command line works.

When same install steps are used w/Ruby 1.9 RubyMine runs test fine.

When searching for answer in discussion groups I thought I noticed someone saying that there is no special support w/in RubyMine for IronRuby (most of threads seemed to be fall of 2009).  Maybe some information about IronRuby support/plans could be added to FAQ.

Thanx

John A

1 comment

Hello John,

no special support w/in RubyMine for IronRuby


It means that RubyMine doesn't know about some IronRuby workarounds/bugs or hacks. So if IronRuby interpreter behavior is close to MRI one then it will be supported by RubyMine.

Should I be able to run rspec tests in RubyMine(2.0.2) using IronRuby 1.0?  RubyMine seemed to install/attach rspec gem w/out an error.

When I run the spec from the IDE I get an error message saying the "requre spec" cannot be loaded/found.

Looks like IronRuby problems.

At the moment I haven't manage to investigate it. My IronRuby 1.0 (rc2) doesn't allow to install gems even from console. And trunk versions has some other bugs. E.g.

1. this cmdline launch spec tests

/Users/romeo/.rvm/gems/ironruby-head/bin/spec /Users/romeo/RubymineProjects/untitled57/foo_spec.rb



2. and this one outputs nothing

/Users/romeo/.rvm/rubies/ironruby-head/bin/ir /Users/romeo/.rvm/gems/ironruby-head/bin/spec /Users/romeo/RubymineProjects/untitled57/foo_spec.rb
0

Please sign in to leave a comment.