Problem using .rvmrc files

I'm using .rvmrc files with custom rubies and gemsets for each project.

RubyMine doesn't seem to recognize the settings inside the .rvmrc file.  I've tried different syntaxes, including:

rvm use 191
rvm use 191@<gemset>
rvm use 1.9.2@<gemset>
rvm use system

None of the options I've tried works.  In every case, I get a little pop-up error message that says:

Project .rvmrc Settings
Cannot find use RVM SDK

Is there a .rvmrc syntax that will be recognized correctly by RubyMine ??

Tx, Andy

ps
RubyMine 2.0.2
Ubuntu 10.04
RVM 0.1.33
Ruby 1.8.7, 1.9.1, 1.9.2 etc.

1 comment
Comment actions Permalink

Hello Andy,

Thank for the question. As far as I know "use" cmd is optional here and I've forgot about it. RubyMine is tested with configs like

   Examples:

    | text                   | dist_name           |     | rvm ruby-1.9.1         | ruby-1.9.1-p378     |     | rvm ruby-1.9.1         | ruby-1.9.1-p378     |     | rvm ruby-1.9.1@foo     | ruby-1.9.1-p378     |     | rvm ruby-1.9.1@na      | [n/a]               |     | rvm 1.9.1              | ruby-1.9.1-p378     |     | rvm 1.9.1@foo          | ruby-1.9.1-p378     |     | rvm 1.9.1@na           | [n/a]               |     | rvm ruby-1.8.7-2010.01 | ruby-1.8.7-2010.01  |     | rvm ruby-1.8.7-p249    | ruby-1.8.7-p249     |     | rvm jruby-1.3.1        | jruby-1.3.1         |     | rvm jruby-1.3.1@foo    | jruby-1.3.1         |     | rvm jruby-1.3.1@na     | [n/a]               |     | rvm jruby-1.3@foo      | jruby-1.3.1         |     | rvm jruby-1.3@na       | [n/a]               |     | rvm 1.3.1              | jruby-1.3.1         |     | rvm 1.3.1@foo          | jruby-1.3.1         |     | rvm 1.3.1@na           | [n/a]               |     | rvm 3@joo              | [n/a]               |     | rvm 1.6                | jruby-1.6.0         |     | rvm 1.9                | ruby-1.9.1-p378     |     | rvm 1.8                | ruby-1.8.7-2010.01  |     | rvm 1.8.7              | ruby-1.8.7-2010.01  |     | rvm 2.0                | ruby-2.0            |


I will add support for "rvm use <..>" format in next RM EAP. I've created an issue - http://youtrack.jetbrains.net/issue/RUBY-6106
0

Please sign in to leave a comment.