Problem with search - 'File ... is too large and cannot be scanned'

Hi,

I am having a problem with search in RubyMine. I press Shift+Command+F to search in project, I type the searched string (i.e. something, which never occurs), select Scope project and do search.

Instead of some results, I get a message

'File [my actual test log] is too large and cannot be scanned.'

It seems, like the search gets stopped on this problem and does not continue (the search tab still shows the previous results). This is annoying - since it prevents me fro mgetting the results - it would be helpful if this message just appears in the result and the search continues.

After some additional testing, I found, that sometimes the search does not terminates on that problem and sometimes it does. It might be related to the fact, that I deleted the file on side. Restarting RubyMine solved the issue.

Any idea, how to get rid of this problem?

Thanks, Michal

3 comments

Hi Michal,

Hi,

I am having a problem with search in RubyMine. I press Shift+Command+F to search in project, I type the searched string (i.e. something, which never occurs), select Scope project and do search.

Instead of some results, I get a message

'File [my actual test log] is too large and cannot be scanned.'

It seems, like the search gets stopped on this problem and does not continue (the search tab still shows the previous results). This is annoying - since it prevents me fro mgetting the results - it would be helpful if this message just appears in the result and the search continues.

After some additional testing, I found, that sometimes the search does not terminates on that problem and sometimes it does. It might be related to the fact, that I deleted the file on side. Restarting RubyMine solved the issue.

Any idea, how to get rid of this problem?

Thanks, Michal

Actually RubyMine should continue searching for occurences after facing with too large file.
Could you please file a bug at http://youtrack.jetbrains.net/issues/RUBY once you get the workflow to reproduce it.
Also please attach log file as described here to the issue: http://www.jetbrains.net/devnet/docs/DOC-1153

Best regards,
Oleg

0

Hi Oleg, thanks for reply. It seems, that I found the reason of the problem. I filed issue RUBY-6069.

In short: it seems, tat the message about big files just hides the message that nothing was found.

Michal

0

Thanks for reporting this!

Regards,
Oleg

0

Please sign in to leave a comment.