Launching RubyMine from Gnome

i'm having issues being able to setup a Launcher from within Gnome to start RubyMine.  I followed the instructions on setting up the command-line to allow for easy RubyMine launching and it works great and I can start RubyMine from anywhere.  But anything I do to create a launcher just doesn't do anything:  no splash screen, no nothing.

On a side note, I did some searching beforehand to try to find this answer so if it's been asked and answered and I missed it I blame my search-fu.

Ubuntu: 10.04
Gnome: 2.30.0
RubyMine: 2.0.2

3 comments

Hi Chris,

i'm having issues being able to setup a Launcher from within Gnome to start RubyMine.  I followed the instructions on setting up the command-line to allow for easy RubyMine launching and it works great and I can start RubyMine from anywhere.  But anything I do to create a launcher just doesn't do anything:  no splash screen, no nothing.

On a side note, I did some searching beforehand to try to find this answer so if it's been asked and answered and I missed it I blame my search-fu. :)

Ubuntu: 10.04
Gnome: 2.30.0
RubyMine: 2.0.2

Are you able to launch rubymine from command line?
I've created a launcher RubyMine.desktop and attached it here.

And it works for me.

Regards,
Oleg



Attachment(s):
RubyMine.desktop.zip
0

oleg_s wrote:

Are you able to launch rubymine from command line?
I've created a launcher RubyMine.desktop and attached it here.

And it works for me.

Regards,
Oleg

I can type 'rubymine' on the command-line from anywhere and RubyMine launches and works flawlessly.  I took a look at your RubyMine.desktop and other than the location of the icons we have the exactly same settings.  Strange.  If it works for you let me play around with it on my end and see what I can discover.

0

The easiest way to investigate this is creating launcher with type "Application in Terminal"
Screenshot-Create Launcher.png
Most likely you'll get the similar error when try to launch it
Screenshot-Untitled Window.png
Please note, that I've intentionally made a mistake in command.

Regards,
Oleg

0

Please sign in to leave a comment.