Bundler + RVM Questions

I'm using 2.0.1 which supposedly supports both RVM and Bundler.

What I don't understand is why Rubymine would ever need to "Install" gems. Aren't my gems bundled in the project? Shouldn't it just parse the gems I have in the project?

I've been fighting with Rubymine all day because it's trying to install gems and then it has problems, and then it wants to install other gems, and then it has problems.

The gems are in the project!


Finally, I got all of my gems installed to the point it would let me run a cucumber spec and I get the following error:

/Users/bjclark/.rvm/rubies/ruby-1.8.7-tv1_8_7_249/bin/ruby -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift) /Users/bjclark/Development/secret_stash/script/cucumber /Users/bjclark/Development/secret_stash/features --format Teamcity::Cucumber::Formatter --expand --tags @wip --color
Testing started at 4:02 PM ...
/Users/bjclark/.gem/ruby/1.8/gems/genki-ruby-terminfo-0.1.1/lib/terminfo.bundle: [BUG] Segmentation fault
ruby 1.8.7 (2010-01-10 patchlevel 249) [i686-darwin10.2.0]

Empty test suite.

Process finished with exit code 134


I don't understand where this gem is even coming from, or why it's throwing a seg fault.

What's going on?!?

9 comments
Comment actions Permalink

regarding bundler: between 0.8 and 0.9 bundler changed things behind the scenes quite a lot. RM 2.0.1 supports 0.8 but get confused with 0.9 as far as I can tell. Hoping they'll fix that in next EAP release when they said they'd look at rails3 stuff.

0
Comment actions Permalink

Hello BJ Clark,

RubyMine 2.0.1 supports bundler <= 0.7 gem, support for 0.9 will be added a bit later. Also RM 2.0.1 understands some old versions of rvm gem, because latest rvm gems provides a bit different ruby interpreter files/folders structure. Comming RM 2.0.2 update will include support for latest rvm gem and bundler 0.8

0
Comment actions Permalink

Hope that last 0.8 is supposed to be 0.9? 0.9 will prob turn into 1.0 for the official rails3 release but seems they've more or less pinned down the interface now so going for 0.9 compability would be very valuable (i'm currently ignoring all gem dependencies in RM).

0
Comment actions Permalink

Definitely bundler 0.9 support wont be included in coming RM 2.0.2 first rc because it is almost ready. At the moment we are working on RubyMine 2.5 which will include Rails 3.0 beta (and thus latest bundler gem) support.

0
Comment actions Permalink

Any idea when the 2.5 EAP will be available?

0
Comment actions Permalink

Most likely in 1-2 months  

0
Comment actions Permalink

Can you tell us what version of Bundler and RVM are supported in 2.0.2RC1? Both are changing so fast that I would like to install the precise versions that Rubymine can support, but I can't figure out which those are.

0
Comment actions Permalink

Bundler 0.8 and rvm 0.1.24. Gemsets for rvm aren't supported yet. Bundler 0.9 support will be available in the next RM 2.0.2 rc

0

Please sign in to leave a comment.