Convert modifier to statement intention appears even though disabled

I've disabled this in the prefs and would expect it to not pop up the light bulb. But for statements such as this it still does:

    return 0 if self.cancelled_type?

3 comments
Comment actions Permalink

Hi Michael,

What did you do exactly?
You could either disable this intention in File|Settings|Extensions - in this case you have to restart RubyMine to apply changes.
Or you can disable it using  File|Settings|Intentions|Ruby|Convert modifier to statetement or using Bulb option Disable this intention?

Regards,
Oleg

0
Comment actions Permalink

I turned everything off in Settings / Intentions awhile ago since I just want quiet editing. The attached screenshots show a freshly launched RubyMine 2.01, the prefs with everything unchecked and the lightbulb popping up.

By the way, I found a way around this. I just moved the modifier_to_statement.rb file out of scripts.

And while I have you, this is a great product. I typically prefer lightweight editors to IDEs but this one rocks. A thousand times better than Eclipse.



Attachment(s):
lightbulb.png
settings.png
0
Comment actions Permalink

Hi Michael,

I turned everything off in Settings / Intentions awhile ago since I just want quiet editing. The attached screenshots show a freshly launched RubyMine 2.01, the prefs with everything unchecked and the lightbulb popping up.

By the way, I found a way around this. I just moved the modifier_to_statement.rb file out of scripts.

Turning off intention in Settings will turn them off in automatical bulb showed. However you can access to intention available by pressing Alt+Enter.
Thus I wasn't able to reproduce you bug.

P.s. Thanks for the warm words, this encourages us to make RubyMine even better!
Regards,
Oleg

0

Please sign in to leave a comment.