"Rubymine requires test-unit gem for SDK >= 1.9" error

Hi to everyone.
I'm on a Mac with Snow Leopard, so I've Ruby 1.8.7.
Recently, 'cause I need some 1.9 features (like Fibers) I've begin to develop with Rubymine on 1.9 through the rvm gem, which allows me to have a "self-contained" ruby 1.9 installation without affecting my original system one.
I've successfully attached the rvm gem to my project and added the 1.9 SDK (pointed from .rvm/rubies/ruby-1.9.1-p378/bin/ruby).
When I try lo launch a simple Test::Unit test I obtain:

"Rubymine requires test-unit gem for SDK >= 1.9. Please attach the gem".
I've installed and attached the test-unit gem, but nothing has changed.

Any ideas?
Thank you very much,
good work

Alfredo Di Napoli

2 comments
Comment actions Permalink

I've filed an issue - http://youtrack.jetbrains.net/issue/RUBY-5750. Our rvm support was implemented for some early version of rvm with different files layout in ~/.rvm directory. We are going to fix our rvm support in coming 2.0.2 version.

0

Please sign in to leave a comment.