Bundler support

Hello all,

I heave a problem with RubyMine's integration with Bundler. My (Rails) project uses Bundler for dependency management, and this also includes tools like rake. Up until recently it wasn't important whether RubyMine executed the systems rake executable or the bundled one, but this is no longer the case for us. I wonder whether there is some configuration option that I could use to make RubyMine use the bundled(./bin/rake) instead of the system gems task?

PS. On the side note, I also noticed that RubyMine forces me (with the yellow popup) to install gems specified in Gemfile into the system gems directory instead of attaching them from the bundled gems directory. Is this also something that could be changed in the current version, or is that planned for some future release?

Best regards,
Adam Pohorecki

2 comments
Comment actions Permalink

Hi Adam,

which version of bundler are you using? They changed gems layout in one of the latest versions and it's not yet supported by RubyMine (see http://youtrack.jetbrains.net/issue/RUBY-5691)

0
Comment actions Permalink

Oh so that must be it, we're using bundler 0.8.1 (newest AFAIK), we also have a custom bundle path (vendor/bundler_gems). Any plans for a bugfix release or EAP (like there was for 1.5/2.0) version?

0

Please sign in to leave a comment.