RubyMine always prompting to allow firewall access on OS X

Every time I fire up RubyMine, OS X prompts me to allow it to accept incoming connections. The dialog shown is:

Do you want the application "RubyMine 2.0.app" to accept incoming network connections?

[Deny] [Allow]

I always click Allow and all is well. But this repeats every time I run RubyMine.

I am still in the trial period, but that shouldn't make a difference. The account I'm logged in to OS X is an administrator and going in to the Firewall settings I have RubyMine 2.0 in the list of allowed apps. "Automatically allow signed software to receive incoming connections" is also checked.

Any help would be appreciated. Thanks.

5 comments
Comment actions Permalink

Which version of MacOS do you use? I don't have such problems on 10.6.2 and I on 10.5 all also worked ok.

0
Comment actions Permalink

Hi Roman,

I'm on OS X 10.6.2 as well.

0
Comment actions Permalink

Roman, is there any other information that may help?

0
Comment actions Permalink

Unfortunately I have no idea. I've just enabled Firewall and MacOS asked me only once about RubyMine connections. Most likely it is MacOS configuration problem.

0
Comment actions Permalink

No worries. Thank you nonetheless.

0

Please sign in to leave a comment.