What rspec version is compatable with the TeamCityRakeRunner Plugin in Rubymine?

I  am getting this exception on Rubymine 2.0 and Rubymine 2.0.1.  I have rspec 1.1.8 installed for OS X.  What is the compatable rspec version needed for the rake runner?  I am also using gem bundler for my project.  I have rspec installed as root and for my user.

TeamCity Rake Runner Plugin isn't compatible with this RSpec version. (Rake::TeamCity::InnerException)

3 comments
Comment actions Permalink

This only happens when I run only one example.  If I run the whole spec file, I don't see the message.

0
Comment actions Permalink

ssims wrote:

I  am getting this exception on Rubymine 2.0 and Rubymine 2.0.1.  I have rspec 1.1.8 installed for OS X.  What is the compatable rspec version needed for the rake runner?  I am also using gem bundler for my project.  I have rspec installed as root and for my user.

TeamCity Rake Runner Plugin isn't compatible with this RSpec version. (Rake::TeamCity::InnerException)

1.1.8 is quite old version. Latest rspec version is 1.2.9. Please update your rspec gem.

0
Comment actions Permalink

I was able to upgrade to rspec 1.1.12 and everything worked ok. I was running rspec 1.1.8 because the deep test gem required it.  I was able to use the source from deeptest instead of the gem and it used a more recent rspec gem.  The gem was last packaged in 2007.

0

Please sign in to leave a comment.