Ubuntu 8.10 - Can't type on text fields in modal dialogs

Congrats for your great work. I've been testing all the RubyMine 2.0 beta versions and finally I've just bought a license.

There's an issue that is happening in all versions, including the new RC1. I'm running RM on Ubuntu 8.10, using GTK+ as the Look&Feel. Sometimes, when a modal dialog appears, the keyboard seems not focused on the dialog. When I type, the keys go to the background window (the editor, the project view, etc.). There's no way to fill the text fields in the dialog, however I can click on the buttons with the mouse. This behaviour remains for all dialogs until I restart the IDE.

Have you had similar problems?

5 comments
Comment actions Permalink

Hi Francisco,

I've been using RubyMine on Ubuntu for quite a long time and I haven't faced with this particular problem, however I've asked responsible developer to have a look at your problem.

Regards,
Oleg

0
Comment actions Permalink

Hi, Oleg

This problem is still happening with the official 2.0 release. I'm also having a similar problem when I'm working with two projects in two different RubyMine windows: sometimes when I switch from one window to the other, pressing Alt+Tab, and I start to write, the keyboard input goes to the previous windows, which is now in the background. No text cursor appears in the foreground window. When I switch again to the first window. I can see the text that I typed.

Also, I upgraded from Ubuntu Hardy to Karmic to see if that fixes the problem, but the behaviour is the same.

Hope it'll help.

Regards,
    Francisco Benavent.

0
Comment actions Permalink

Hi Francisco,

Thanks for reporting this, I can recommend you to tweak Java look and feel of your application in File | Settings | Appearance | Look and Feel
Hope this helps.

Regards,
Oleg

0
Comment actions Permalink

i have the same problem on ubuntu 8.10

0
Comment actions Permalink

I've found a way to reproduce the problem with the keyboard focus in two RubyMine windows:

  1. Open two RubyMine projects in two different windows.
  2. Open another app in a third window, for example a Terminal window
  3. When in the first RubyMine window, change pressing Alt+Tab to the Terminal window
  4. Change again pressing Alt+Tab to the second RubyMine window
  5. Now type something: while the active window is the second, keyboard input goes to the first window.


Note that this doesn't happens when you switch directly for one RubyMine window to another; only when you switch to an intermediate window.

Hope you'll be able to reproduce it too.

Thanks,
    Paco.

0

Please sign in to leave a comment.