RubyMine 2.0 unable to debug

Hi all -

I am quite new to ruby and RubyMine so please be gentle
Anyway, I am running (or attempting to ) run RubyMine2.0 on Ubuntu. When I try to debug a simple script I get a message dialog which says.

"The gem ruby-debug-ide19 required by the debugger isnot currenlty installed. Would you like to install it?"
When I click yes I get an error dialgo (a big one)

Error running TestRuby: Failed to install gems. Follwing gems were not installed
ruby-debug-ide19: Error installed ruby-debug-ide19
etc........

The ruby1.9 SDK is selected in my RubySDK and Gems page on RubyMine. I also installed gems for 1.9 as well.

What am I missing here? Any help is appreciated!

9 comments
Comment actions Permalink

Hi Carl,

I am quite new to ruby and RubyMine so please be gentle :)
Anyway, I am running (or attempting to ) run RubyMine2.0 on Ubuntu. When I try to debug a simple script I get a message dialog which says.

"The gem ruby-debug-ide19 required by the debugger isnot currenlty installed. Would you like to install it?"
When I click yes I get an error dialgo (a big one)

Error running TestRuby: Failed to install gems. Follwing gems were not installed
ruby-debug-ide19: Error installed ruby-debug-ide19
etc........

The ruby1.9 SDK is selected in my RubySDK and Gems page on RubyMine. I also installed gems for 1.9 as well.

What am I missing here? Any help is appreciated!

Please attach here

ruby1.9 -S gem list
command output.
Can you install ruby-debug-ide19 gem from command line for ruby1.9?

sudo ruby1.9 -S gem install ruby-debug-ide19

Regards,
Oleg

0
Comment actions Permalink

Here is the output

carl@carl-laptop:~$ ruby -S gem list

*** LOCAL GEMS ***

actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
rack (1.0.1)
rails (2.3.4)
rake (0.8.7)
carl@carl-laptop:~$


After trying to install ruby-debug-ide i get an error -----

carl@carl-laptop:~$ sudo gem install ruby-debug-ide
[sudo] password for carl:
Building native extensions.  This could take a while...
ERROR:  Error installing ruby-debug-ide:
    ERROR: Failed to build gem native extension.

/usr/bin/ruby1.8 mkrf_conf.rb
Building native extensions.  This could take a while...


Gem files will remain installed in /var/lib/gems/1.8/gems/ruby-debug-ide-0.4.9 for inspection.
Results logged to /var/lib/gems/1.8/gems/ruby-debug-ide-0.4.9/ext/gem_make.out
carl@carl-laptop:~$


After checking the log file I only see this

/usr/bin/ruby1.8 mkrf_conf.rb
Building native extensions.  This could take a while...


Thanks for your help!

0
Comment actions Permalink

In `which gem` file the first line contains path to ruby interpreter in shell style, does it point to ruby1.9?

0
Comment actions Permalink

oleg_s wrote:
In `which gem` file the first line contains path to ruby interpreter in shell style, does it point to ruby1.9?

I removed 1.9 thinking that having both 1.8 and 1.9 installed might be an issue.

Here is the contents of /usr/bin/gem

#!/usr/bin/ruby1.8
#--
# Copyright 2006 by Chad Fowler, Rich Kilmer, Jim Weirich and others.
# All rights reserved.
# See LICENSE.txt for permissions.
#++

require 'rubygems'
require 'rubygems/gem_runner'
require 'rubygems/exceptions'

required_version = Gem::Requirement.new "> 1.8.3"

unless required_version.satisfied_by? Gem.ruby_version then
abort "Expected Ruby Version #{required_version}, was #{Gem.ruby_version}"
end

args = ARGV.clone

begin
  Gem::GemRunner.new.run args
rescue Gem::SystemExitException => e
  exit e.exit_code
end

0
Comment actions Permalink

#!/usr/bin/ruby1.8

This line shows that gem launches ruby1.8 as ruby interpreter, thus ruby1.9 has nothing to do with it.
Please ensure you have build-essential package installed on your system.
     dpkg --list | grep build-essential
If output is empty install them using
     sudo aptitude install build-essentia

Regards,
Oleg

0
Comment actions Permalink

oleg_s wrote:

#!/usr/bin/ruby1.8

This line shows that gem launches ruby1.8 as ruby interpreter, thus ruby1.9 has nothing to do with it.
Please ensure you have build-essential package installed on your system.
     dpkg --list | grep build-essential
If output is empty install them using
     sudo aptitude install build-essentia

Regards,
Oleg

build-essential does seem to be installed.

carl@carl-laptop:~$ dpkg --list | grep build-essential
ii  build-essential                       11.4                                             Informational list of build-essential packag
carl@carl-laptop:~$

I have since removed ruby1.9 and now only have ruby1.8 on my system. /usr/bin has two files a /usr/bin/ruby and a /usr/bin/ruby1.8 file.

0
Comment actions Permalink

Please ensure you have ruby-dev Ubuntu package installed.

0
Comment actions Permalink

oleg_s wrote:

Please ensure you have ruby-dev Ubuntu package installed.

Oleg! You are my HERO!

Seriously, I really appreciate your help - everything seems to be working correctly now.

0
Comment actions Permalink

Glad to hear! Develop with pleasure!

0

Please sign in to leave a comment.