Memory consumption and L&F of application

Hello,

recently started using RubyMine 2.0 beta 3 on 64-bit Ubuntu Linux. With opened project, but without any file in editor the IDE uses about 200Mb of RAM. On windows it's about 70Mb. I'm using 64-bit Sun JDK.

When I started the application under IcedTea (default on Ubuntu) it looked terribly. After setting GTK theme, it got a bit better, however that wasn't still comparable with the Windows or MacOSX version. So I tried installing Sun JDK, which contains Nimbus, it looks OK now, however I would prefer native L&F.

M.

3 comments
Comment actions Permalink

Hi Marek,

recently started using RubyMine 2.0 beta 3 on 64-bit Ubuntu Linux. With opened project, but without any file in editor the IDE uses about 200Mb of RAM. On windows it's about 70Mb. I'm using 64-bit Sun JDK.

When I started the application under IcedTea (default on Ubuntu) it looked terribly. After setting GTK theme, it got a bit better, however that wasn't still comparable with the Windows or MacOSX version. So I tried installing Sun JDK, which contains Nimbus, it looks OK now, however I would prefer native L&F.

To run Rubymine correctly Sun Java is required because there are loads of known issues with OpenJdk and IcedTea as well. Why don't you like GTK+ Look and Feel?
It looks quite native for me on Ubuntu 9.10 x64.

As for the memory consumption we recommend you to increase default JVM settings in file bin/rubymine.vmoptions because defaults were optimized for 32bit Java.

Regards,
Oleg

0
Comment actions Permalink

Not exactly java optimization guru, I'll try to get into the memory tunning later.

To L&F .... when I started GTK, the IDE collapsed, so I had to restart it. Just one time operation, not such a big deal. However, the theme's fonts are too small. Changing values in Settings didn't help. The select box for choosing configuration to run project was a complete mess. That's what I can remember now.

M.

0
Comment actions Permalink
To L&F .... when I started GTK, the IDE collapsed, so I had to restart it. Just one time operation, not such a big deal. However, the theme's fonts are too small. Changing values in Settings didn't help. The select box for choosing configuration to run project was a complete mess. That's what I can remember now.

Could you please attach logs as described here: http://www.jetbrains.net/devnet/docs/DOC-1153?

0

Please sign in to leave a comment.