Inconsistent rspec test running w/in rubymine 2.0 beta

Hi,

I using 2.0 beta build 1436, ruby 1.9.1p243,  and rspec 1.2.8, Win 7 build 7100 (64 bit).

If I read the help correctly I should be able to execute a single test by right click in a test and choose the "Run "some test name" from the context menu.

The "Run" menu item appears w/what appears to the context content.( when i click on "it" statment or a line w/in "it do/end")

When I run the test I observe "No tests were found" in testing window. Also see "Empty test suite".

There are a number of "context" blocks in the test file.  Right clicking on a context block displays the name of the file in the "Run"context menu and causes all tests to be ran.  Should only the tests in context block be ran?

Also I cannot run any tests unless I add a require 'spec' statement to test file.  I tried requiring a file that had "require 'spec'" in it but that did not work.  Searched the discussing group and I thought I saw a post that said that should work.

I'm following along the RSpec book to create tests.

Thanx

John A.

Please sign in to leave a comment.