Why is the Ruby plugin releases lagging?

It's now been a month since the last Ruby plugin release for IDEA. Can we please get an updated plugin which works with the latest IDEA EAP? I find it frustrating that the Ruby plugin is always lagging behind the latest IDEA EAP. I generally have to choose to use the latest EAP without Ruby or an older EAP with Ruby.

6 comments
Comment actions Permalink

Unless you need JRuby integration you can always download RubyMine separately -- that's what I've been doing: IDEA for my Java projects, RubyMine for my Ruby projects.

I actually like what JetBrains is doing. RubyMine as a separate product gives the Ruby team more freedom to develop new features without worrying about backwards compatibility for a while. Remember this is still an early access.

0
Comment actions Permalink

In fact, I do need JRuby support.

0
Comment actions Permalink

It's been over 3 months! since the last Ruby plugin release. Is it still under development or has it been scrapped in favor of RubyMine?

0
Comment actions Permalink

Hello Shane,

Our latest versions of Ruby plugin are compatible only with trunk Maia(IDEA 9) builds. It isn't a marketing, just lot's of new Ruby Plugin/RubyMine features lead to changes in IDEA API. Updated plugin will be available for Maia release. Sorry for inconvenience.

0
Comment actions Permalink

Does that mean that we'll ever see a plugin release that works with the Maia EAP?

0
Comment actions Permalink

Hello Kurt,

The Maia-compatible version of the Ruby plugin will be released after the
IntelliJ IDEA 9.0 beta release.

Does that mean that we'll ever see a plugin release that works with
the Maia EAP?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.