Open file in editor with one click

I have one project set up so that when I single-click a file in the "Project" window it opens in the "Editor" window, i.e. I don't have to double-click a file to open it.

I just created a new project and I need to double-click a file to open it. I have been through the "Settings" 3 or 4 times (obviously not enough) and for the life of me I can't find that "single-click to open" setting.

Can someone tell me where it is?

Thanks,
Larry

P.S. BTW, I switched from NetBeans several months ago and have never regretted it. Thank you for a great product and keep up the good work!

6 comments
Comment actions Permalink

Hello Larry,

P.S. BTW, I switched from NetBeans several months ago and have never regretted it. Thank you for a great product and keep up the good work!

Thanks for these nice words =)


I suppose you are talking about "Autoscroll to Source" option in Project View, see screenshot
Screen shot 2009-09-17 at 13.07.09.png

2
Comment actions Permalink

Also you can always perform this using action View | Jump To Source action that has keyboard shortcut F4 on Windows and Linux boxes.

0
Comment actions Permalink

Arrgghh... no wonder I couldn't find it in the settings!     Well,  that will teach me to start writing this stuff down.

As always, thanks a bunch for the quick support,
Larry

0
Comment actions Permalink

Thanks, I've finally found it.

By the way, I suggest that you might need to rethink about the feature name. "Autoscroll To Source" is misleading and doesn't convey the expected functionality to me. Something like "instant open" or "1-click open" is more sensible to me.

8
Comment actions Permalink

Note a single click will not put cursor focus into the file. I can't tell you how many times I've clicked a file and started typing only to realize I was actually navigating the project tree.

0
Comment actions Permalink

I googled this for opposite reason, somehow I had turned it on without realisng, and whatever I clicked on was opening the file. Which I was finding extremely annoying. So I am glad to have been able to turn it off again.

0

Please sign in to leave a comment.