Rubymine 1.1 (975) wont start

Hi I attempt to use rubymine (latest version from on OpenSuse 11.1.

When I start the startup script in rubymine975/bin nothing happens.

When I start the script using the -x flag IT hangs here:

+ exec /etc/alternatives/jre/bin/java -Xms32m -Xmx512m -XX:MaxPermSize=150m -ea -Xbootclasspath/a:../lib/boot.jar -Didea.platform.prefix=Ruby com.intellij.idea.Main

I checked the idea.log file and it reports these errors:

2009-08-31 10:07:01,838 [    348]   INFO - cense.rubymine.RubyMineLicense - Network startup failed.
2009-08-31 10:07:02,091 [    601]  ERROR -   #com.intellij.util.ui.UIUtil - null

Network is up of course

java.lang.Error: Cannot load com.birosoft.liquid.LiquidLookAndFeel


2009-08-31 10:07:02,105 [    615]  ERROR -   #com.intellij.util.ui.UIUtil - JDK: 1.6.0_15
2009-08-31 10:07:02,105 [    615]  ERROR -   #com.intellij.util.ui.UIUtil - VM: Java HotSpot(TM) Client VM
2009-08-31 10:07:02,105 [    615]  ERROR -   #com.intellij.util.ui.UIUtil - Vendor: Sun Microsystems Inc.
2009-08-31 10:07:02,105 [    615]  ERROR -   #com.intellij.util.ui.UIUtil - OS: Linux
2009-08-31 10:07:02,105 [    615]  ERROR -   #com.intellij.util.ui.UIUtil - Original exception:
java.lang.Error: Cannot load com.birosoft.liquid.LiquidLookAndFeel
        at javax.swing.UIManager.initializeDefaultLAF(
        at javax.swing.UIManager.initialize(
        at javax.swing.UIManager.maybeInitialize(
        at javax.swing.UIManager.getUI(
        at javax.swing.JPanel.updateUI(


2009-08-31 10:07:02,150 [    660]  ERROR - llij.ide.plugins.PluginManager - null

I have tried the java package that come with opensuse (sun version) as well as the rpm package from that produced this log file. I just reinstalled my distro and have successfully used rubymine before. So I am a bit startled about this.

Any help would be appreciated.

Cheers Klaus

/etc/alternatives/jre/lib/ext/liquidlnf.jar does exist.

Comment actions Permalink

I forgot to mention that other java apps like Jalbum and me fall back IDE Aptana Studio work just fine.

Comment actions Permalink

There was a non functional package called "liquidlnf" which I had to remove. Then I also had to edit this file:


and had to remove any line in regard to the liquid style.

Now it works just fine.

Cheers Klaus

Comment actions Permalink

Thank you for a workaround!


Please sign in to leave a comment.