SSH passphrase always requested when performing git push

I love the git integration in RubyMine but there is one annoyance.  Whenever I 'git push' RubyMine will prompt for my SSH passphrase.  I'd like this to be saved or, ideally, to use ssh-agent on my Mac so that it automatically pushes without prompting.

Is this something you might consider?

6 comments
Comment actions Permalink

The current workaround is to use unencrypted private keys. The problem is caused by using Java implementation of SSH since native implementatio did not work on some platforms.

There is already a similar feature request: http://www.jetbrains.net/jira/browse/IDEADEV-37127. Please watch this request for further progress on the issue.

We are considering to reenable native implementation on platforms where it works.

0
Comment actions Permalink

Hi,

I agree with the original post in that I love your Git integration (that and Cucumber/RSpec support are the main reasons I switched from NetBeans), but find it annoying to always have to enter my passphrase. Two more cents on this topic:

  1. The "feature request" link you give describes this issue as being resolved and fixed. Is that true? If so... it's not, as far as I can tell.
  2. For pulls I have to enter my passphrase twice: once for the "Get Branches" operation in the Pull dialog box, then, after that displays "master" and I check it, I have to enter it again to actually pull the changes. This is really annoying; Subversion (which I used to use) was waaaay easier to interact with.


Thanks,
Larry

P.S. BTW, no regrets from leaving NetBeans for RubyMine. Keep up the great work!

0
Comment actions Permalink

Hi Larry,

You can ask RubyMine to use your native SSH agent and passphrase will be asked only once. Which OS do you use?

MacOS instructions:
1. ssh-agent should be installed on your Mac. Leopard has bundled ssh-agent and you needn't install it manually
2. Open RubyMine | File | Settings | Version Control | VCSs | Git tab and choose "Native" SSH executable.
Picture 11.png
3. Also on MacOS you need add "/usr/bin"($which ssh) folder to your PATH env variable using ~/.MacOSX/environment.plist (see our article  Tip: How to setup Environment variables for RubyMine on Mac OS X)
Picture 13.png

0
Comment actions Permalink

Hi Roman,

Thanks for the reply. I run Ubuntu Linux (9.04) and don't seem to have an SSH Executable option for my Git settings. Does that mean I'm out of luck?

-- Larry

0
Comment actions Permalink

Roman.Chernyatchik wrote:

Hi Larry,


You can ask RubyMine to use your native SSH agent and passphrase will be asked only once. Which OS do you use?


MacOS instructions:
1. ssh-agent should be installed on your Mac. Leopard has bundled ssh-agent and you needn't install it manually
2. Open RubyMine | File | Settings | Version Control | VCSs | Git tab and choose "Native" SSH executable.
Picture 11.png
3. Also on MacOS you need add "/usr/bin"($which ssh) folder to your PATH env variable using ~/.MacOSX/environment.plist (see our article  Tip: How to setup Environment variables for RubyMine on Mac OS X)
Picture 13.png


Hi Roman,

I don't have the SSH option on this page.  Is there something I need to do to enable it?  I'm running RubyMine 1.1 build 975 on OSX Leopard.

Olly

0

Please sign in to leave a comment.