Lots of warnings, for ActiveRecord methods

Hello
I am trying RubyMine with 1.5 EAP,
I am gettig lots of warnings in every model, one for each ActiveRecord method (validations, associations, etc)
The gem for ActiveRecord does not appear in the libraries of the project.
Is this a problem of my installation?

Thanks

1 comment
Comment actions Permalink

Hello Juan,

Hello

I am trying RubyMine with 1.5 EAP,
I am gettig lots of warnings in every model, one for each ActiveRecord method (validations, associations, etc)
The gem for ActiveRecord does not appear in the libraries of the project.
Is this a problem of my installation?
Thanks

Please ensure your project SDK is configured properly and you have all the nescessary gems attached to your project.
You can configure Ruby SDK and Gems in File | Settings | Ruby SDK and Gems.
What Gems are attached at the moment? You should have activerecord gem attached to your project. You can attach rails gem, RubyMine should will attach all the dependencies automatically.

Regards,
Oleg

0

Please sign in to leave a comment.