EAP 1.5 gems support insisting on postgres

Just a nit about the gem management. It is complaining about not being able to install postgres. I'm not sure why it thinks postgres is required for my project? I don't use it. Rails 2.3.2 .

But, really, I'm am enjoying this Rubymine thing a lot. I'd about gotten bored with RoR, but its my toy of choice again. Keep these neat updates coming -- I'm off to learn haml, finially.

Gordon

3 comments
Comment actions Permalink

Just a nit about the gem management. It is complaining about not being able to install postgres. I'm not sure why it thinks postgres is required for my project? I don't use it. Rails 2.3.2

Is postgres adapter mentioned in your database.yml? Or probably gem is mentioned in environment.rb file or other configuration files in ./config/environments folder.

P.S: I've created new rails 2.3.2 project and RubyMine doesn't suggest me to install postgres gem

0
Comment actions Permalink

Thanks for the good hint. I found the cause but it is
a little murky:  I have the mislave-will_paginate plugin installed. And that
has test cases. And in the test directory there has a database.yml which
does have a postgres configuration.But it took a string search on the whole
project to turn this up. I wonder it the error message reporting the missing
GEM should include the (first?) file using the GEM?

And I suppose there is the question: does a project require the GEMs needed to
test the plug-ins it uses?

And, as ususal, thanks for the good reply.

0
Comment actions Permalink

Gordon, thank  you for the report. I've filled a bug against database gem detector: http://jetbrains.net/jira/browse/RUBY-4510 and added feature request for viewing origin of gem requirement:  http://jetbrains.net/jira/browse/RUBY-4511

Feel free to watch their status and vote for them.

0

Please sign in to leave a comment.