rails gem isnt activated for module error

Hi,
I'm getting the error message 'rails gem isnt activated for module error' but then i go into my gem manager, rails show there as been in the project, do you have any ideas why this would be happening? thanks for your help.

0
19 comments

but then i go into my gem manager, rails show there as been in the project.

You mean in "RubyMine's Gem manager" or you execute 'gem list' command ?

0

I'm getting the error message 'rails gem isnt activated for module error'

As far as I understand you should see this error in run configuration settings. Could you make a screenshot?

0

I got the same problem, I just created the project, and choose run, got the same error.

If I start the project from command line (not inside ide), the project actually run.

Any idea?

Thanks,
J.W.

0

I have to up, up this question again, can anybody at JetBrains give us a clue?

0

Hello Yuren,

We are thinking on Robert's problem. I'm not sure that you faced with the same one. Let's check:
1. Please open  File | Settings | RubySDK and Gems manager tab and check if "rails" gem is attached to project. Or better show us screenshot of this tab.
2. Which OS do you use?

0

Here is my screenshot, and I am on windows xp.

I think I have the exact same error as Robbert.



Attachment(s):
CropperCapture[17].Png
0

Thank you, I'll be glad to provide you with any information you may need, just let me know.

0

I think I have the exact same error as Robbert.

You are right, it seems the same problem. Please also attach idea.log as described at http://www.jetbrains.net/devnet/docs/DOC-1153

0

OK, I attached the log with this message.



Attachment(s):
idea.log
0

Roberto, please also attach your idea.log as described athttp://www.jetbrains.net/devnet/docs/DOC-1153

0

Thank you for the log, I've noticed exception there which is related to RubyMine's Gem Manager, see http://www.jetbrains.net/jira/browse/RUBY-4327

0

I see the ticket shows that it is fixed, can I get an update, or can you provide a workaround for me?

Thanks,
Jianwei

0

any workaround? Does rubymine has a nightly build?

0

Hello,

We implemented to suggested fixes according to your today's Robert's logs. We weren't able to reproduce the problem and we are not sure that our fix will help for the problem so we are still thinking on it. Anyway we are going to publish new build with current fixes in a week. As for nightly builds JetBrains doesn't provide public night builds for RubyMine.

0

I uninstalled rubymine and reinstall it, it seems working now.

I still would like to know why, but it works for me now.

0

Please sign in to leave a comment.