JRuby 1.3.1 SDK - Gems Missing

I am adding a JRuby 1.3.1 SDK to RubyMine 1.1 by specifying the bin\jruby.bat file. After doing so, no Gems appear in the installed list even though I have installed some at the command line.

OS - Windows
Environment

set JRUBY_HOME=c:\ruby\jruby-1.3.1
set JAVA_HOME=c:\java\jdk1.6.0_12
set PATH=%JRUBY_HOME%\bin;%JAVA_HOME%\bin;c:\WINDOWS\system32;c:\WINDOWS;c:\WINDOWS\System32\Wbem

Only the "Install Gems" button is enabled and though I can list gems, pressing Install appears to do nothing.

From the command line...

C:\ruby\jruby-1.3.1\bin>jruby -S gem list --local

*** LOCAL GEMS ***

actionmailer (2.3.2)
actionpack (2.3.2)
activerecord (2.3.2)
activeresource (2.3.2)
activesupport (2.3.2)
glassfish (0.9.5)
jruby-openssl (0.5.1)
rack (1.0.0)
rails (2.3.2)
rake (0.8.7)
rspec (1.2.6)
sinatra (0.9.2)
sources (0.0.1)

Does anyone have suggestions as to steps I can take to troubleshoot this problem?

Thanks much,
Tim

3 comments
Comment actions Permalink

Hello Tim,

Please attach idea.log as described at http://www.jetbrains.net/devnet/docs/DOC-1153

0
Comment actions Permalink

Thanks Roman,

I do have an update for this issue.I believe the problem was my not understanding how RubyMine works. I did not have a Rails project open at the time I was setting the SDK. After opening an existing project, the gem list was populated.

I have attached the log file regardless but the errors were all logged after I opened the Rails project.

Tim



Attachment(s):
idea.log
0
Comment actions Permalink

Hello Tim,

RubyMine uses notion of "attached gems". This is necessary for RubyMine's code insight features and doesn't related to behaviour of your ruby application on runtime. If you are using some gem in your application please "attach" it in RubyMine's Gem Manager. RubyMine is able to automatically attach gems mentioned in environment.rb of rails application. Also RubyMine show "quick fix" on unresolved  *gem*/*require*calls which allow to attach or install corresponding gems.

0

Please sign in to leave a comment.