Web Preview Doesn't Work

Hi,

I'm using Ubuntu 9.04. When I first fired up RubyMine the "Web Preview" window was grayed out and informed me that I had to download the necessary plugins in order for it to work. (This was yesterday => I can't remember exactly what it said.) Anyway, I did what it requested and now the window shows up with the icons, URL field, etc.

But when I try to display something - either a remote site or my local app (which is running on FireFox) - I get nothing but the "wait" cursor, so finally I just click the "Stop" icon. Am I missing something?

Also, I'm not even sure I'd use this window, but there doesn't seem to be a way to get rid of it permanently. Other Tool Windows have a big red "X" icon so you can close them, but this one doesn't. Just noticed that the TODO window doesn't have an "X" either. Is this by design? Is there a way to permanently close windows we don't want open? It seems to me there must be, seeing as how there are literally thousands of customizable settings.

BTW, I am RTFMing. In fact, I'm going through every single page of the "Help" in an attempt to see what this IDE can do. But there's just so much stuff it's hard to find what you are looking for.

Thanks,
Larry

4 comments
Comment actions Permalink

Hello Larry,

You can disable the Web Preview plugin in Settings | Plugins.

I'm using Ubuntu 9.04. When I first fired up RubyMine the "Web
Preview" window was grayed out and informed me that I had to download
the necessary plugins in order for it to work. (This was yesterday =>
I can't remember exactly what it said.) Anyway, I did what it
requested and now the window shows up with the icons, URL field, etc.

But when I try to display something - either a remote site or my local
app (which is running on FireFox) - I get nothing but the "wait"
cursor, so finally I just click the "Stop" icon. Am I missing
something?

Also, I'm not even sure I'd use this window, but there doesn't seem to
be a way to get rid of it permanently. Other Tool Windows have a big
red "X" icon so you can close them, but this one doesn't. Just noticed
that the TODO window doesn't have an "X" either. Is this by design? Is
there a way to per

manently close windows we don't want open? It seems to me there must
be, seeing as how there are literally thousands of customizable
settings.

BTW, I am RTFMing. In fact, I'm going through every single page of the
"Help" in an attempt to see what this IDE can do. But there's just so
much stuff it's hard to find what you are looking for.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,

Thanks for your reply. I might not disable it if I liked it. Do you have any idea why it isn't working?

Thanks,
Larry

0
Comment actions Permalink

As far as I know it doesn't work with 64bit java

0
Comment actions Permalink

Hi Roman,

Thanks for your reply. My computer is a 32-bit machine.

-- Larry

0

Please sign in to leave a comment.