Full path in gem library names causes problems with sharing .iml files

The full path to the gems is giving us headaches while sharing iml files.

We pack up our entire jruby install in our VCS, so we can just check out and start working. Unfortunantly, this causes a problem where IntelliJ is constantly renaming the references to the gem, i.e:

-    <orderEntry type="library" name="[gem] rspec (v1.2.6, /Users/geoff/Dev/code/conf/vms/ruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rspec-1.2.6)" level="application" />
+    <orderEntry type="library" name="[gem] rspec (v1.2.6, /Users/kurt/code/trunk/conf/vms/ruby/jruby-1.2.0/lib/ruby/gems/1.8/gems/rspec-1.2.6)" level="application" />

Is there some way to turn off this constant renaming of the gem references?

2 comments
Comment actions Permalink

We have a similar issue. Is there a way to change the name generator to not include the path ?

Or move this part of the configuration to the workspace.xml, as it clearly is user specific ?

0
Comment actions Permalink

Hello, Kurt,

that's a known issue, please vote for it (in this case you'll follow it as well):

https://youtrack.jetbrains.com/issue/RUBY-18218 

0

Please sign in to leave a comment.