Issue getting SVN to work with RubyMine 1.0.5

Hi there,

I'm running RubyMine 1.0.5 and I've pointed it to my Rails app.  SVN works find from the command line but when I try and invoke Subversion commands via RubyMine, it's not working.  Can anyone help?

Here's what happens when I try and run a 'Compare with' Subversion command?

Picture 1.png

What's the correct procedure to configure SVN for an existing project?  Should RubyMine automatically pick up the SVN details from the .svn files in my project?

3 comments
Comment actions Permalink

Here's another example.  Note I have set the project root correct in the project settings.

Picture 2.png

0
Comment actions Permalink

What's your command line svn version? RubyMine is not yet compatible with svn 1.6, so if you're using it you're out of luck. Try downgrading your working copy to 1.5 or performing a fresh checkout from RubyMine. Also, you'll have to downgrade your command line svn to 1.5 as well, or refrain from using it on working copies used by RubyMine, since svn will automatically upgrade any working copies it touches.

0
Comment actions Permalink

pazu wrote:

What's your command line svn version? RubyMine is not yet compatible with svn 1.6, so if you're using it you're out of luck. Try downgrading your working copy to 1.5 or performing a fresh checkout from RubyMine. Also, you'll have to downgrade your command line svn to 1.5 as well, or refrain from using it on working copies used by RubyMine, since svn will automatically upgrade any working copies it touches.

Pazu

Thanks for your feedback, you're absolutely right -- I was using svn 1.6.1.  I've downgraded back to the OSX default of 1.4.4, checkout out my project again and everything seems fine.

Thanks!

0

Please sign in to leave a comment.