Specious warning when not using activerecord.


I have a jruby project which does not use activerecord, and it is
explicitly removed from the stack in environment.rb

config.frameworks -=

When I configure my jruby sdk, there is a warning at the bottom

"Gems required for project are not attached:
activerecord-jdbcsqlite3-adapter"

Everything works fine, but the warning is misleading.

cheers,
Charles

1 comment
Comment actions Permalink

Hello Charles,

I have a jruby project which does not use activerecord, and it is

explicitly removed from the stack in environment.rb


config.frameworks -= :active_record, :active_resource


When I configure my jruby sdk, there is a warning at the bottom


"Gems required for project are not attached:
activerecord-jdbcsqlite3-adapter"


Everything works fine, but the warning is misleading.

I've filled an issue: http://www.jetbrains.net/jira/browse/RUBY-3852

Best regards,
Oleg

0

Please sign in to leave a comment.