Gems Installer - Install required dependency xxxxxx? [Yn]

I'm running on Build 824 and my question concerns the automatic installation of dependent Gems. On nearly every Gem I attempt to install, I see a message on the Gem installation dialog near the bottom which asks the question:

"Install required dependency xxxxxx? [Yn]"

Having selected the "Automatically add dependent gems" checkbox, I would have assumed that this was only an indication that a dependent Gem was required and that it was begin installed. However, the Gem install never completes and I'm wondering if I am supposed to confirm with either 'Y' or 'n' to indicate my choice. I have tried that and nothing works. I eventually have to cancel the Gem installation.

Something else I've noticed is that the Gem listbox is broken (or very slow to load the gem list) and, at least on my machine, only lists gems up to "FotoVerite-fotoverite-babygitter ". I usually need to delete the gems "source_cache" file and let RubyMine rebuild the list slowly before it works again (i.e. lists all available gems from a-z).

Am I doing something incorrectly or is this behavior described somewhere I missed?

Thanks,
-bill



Attachment(s):
untitled.PNG
3 comments
Comment actions Permalink

Could you please report output of

gem --version

?
Bug with installation of dependent gems for gem <=0.9.5 is fixed and fix will be available in the next build.
You could run

gem update --system

as a workaround. This also may fix issue with downloading gem list

0
Comment actions Permalink

gem --version ==> 0.9.4

Thanks,
-bill

0
Comment actions Permalink

If anyone else reads this at some point the suggested solution from Dennis worked:

gem update --system

I am now able to use the RubyMine IDE to perform Gem management. The performance issues as well as the dialog message I indicated in a previous post are resolved.

Thanks again Dennis.

-bill

0

Please sign in to leave a comment.